[Libreoffice] [stephan.bergmann at oracle.com: Re: [releases] Minutes for release status meeting from 2010-11-15]

Rene Engelhard rene at debian.org
Tue Nov 16 05:03:53 PST 2010

----- Forwarded message from Stephan Bergmann <stephan.bergmann at oracle.com> -----

Date: Tue, 16 Nov 2010 13:12:28 +0100
From: Stephan Bergmann <stephan.bergmann at oracle.com>
To: releases at openoffice.org
Subject: Re: [releases] Minutes for release status meeting from 2010-11-15
Reply-To: releases at openoffice.org
User-Agent: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:
	Gecko/20100610 Lightning/1.0b2 OracleBeehiveExtension/
	ObetStats/CAT_1288249554481-412515569 Thunderbird/3.1

> (15:04:46) ***_rene_ thinks he found a stopper, sb was CCed on that mail :)
> (15:04:53) _rene_: looks like ure lost symbols and became incompatible :-)
> (15:05:57) stefan_b: Mail? What about an issue?
> (15:06:08) _rene_: no.
> (15:06:20) _rene_: it's per mail because it originated from mail
> (15:06:57) ***mdamboldt can't get hold of sb right now :(
> (15:07:37) stefan_b: forwarding the relevant parts to a public place would ease communication.
> (15:07:59) _rene_: it *is* on a public place :)
> (15:08:06) _rene_: debian bts and libreoffice mailinglist :)
> (15:08:21) _rene_: (http://bugs.debian.org/603549)
> (15:08:59) _rene_: *probably* caused by this:
> (15:09:02) _rene_: Author: sb <sb at openoffice.org>
> (15:09:05) _rene_: Date: Fri Jan 29 17:01:54 2010 +0100
> (15:09:08) _rene_:
> (15:09:12) _rene_: sb118: #i108776# changed addsym.awk to also export STLport num_put symbols,
> (15:09:17) IZBot: tools DEFECT CLOSED FIXED P3 export all num_put symbols http://qa.openoffice.org/issues/show_bug.cgi?id=108776
> (15:09:18) _rene_: +and simplified it by requiring that first section is labeled UDK_3_0_0; adapted
> (15:09:21) _rene_: +map files accordingly, replacing many individual ones with solenv/src templates

The fix for <http://qa.openoffice.org/issues/show_bug.cgi?id=108776>
indeed inadvertently broke compatibility by changing symbol version
names exported from the jvmaccess library.  Thanks to René for finding
this issue.

The effect is that an office installation based on OOo before 3.3
cannot share a URE installation with an office installation based on
OOo 3.3 or later.  Sharing URE installations is only relevant on Linux
and Solaris, not on Windows and Mac OS X, and is probably more of
theoretical than practical concern.

Furthermore, the jvmaccess library is considered a private part of the
URE (see <http://hg.services.openoffice.org/OOO330/file/e13523b45392/ure/source/README#l68>),
so especially no OOo extensions should link against it (which might
otherwise cause problems, causing those extensions to not work across
the OOo 3.3 boundary).  The OOo basis layer code violates this privacy
and does link against the library, causing the incompatibility to be

Given this state of affairs, I do not think this issue should be
considered a stopper for OOo 3.3.


To unsubscribe, e-mail: releases-unsubscribe at openoffice.org
For additional commands, e-mail: releases-help at openoffice.org

----- End forwarded message -----



More information about the LibreOffice mailing list