Mesa (master): dri/r200: rename __atom to current_atom.

Stephane Marchesin marcheu at kemper.freedesktop.org
Fri Jun 24 03:58:25 UTC 2011


Module: Mesa
Branch: master
Commit: 5f691ba36fc52da3f0565c238c1f892422f7d439
URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=5f691ba36fc52da3f0565c238c1f892422f7d439

Author: Stéphane Marchesin <marcheu at chromium.org>
Date:   Thu Jun 23 20:53:47 2011 -0700

dri/r200: rename __atom to current_atom.

__atom is defined by gcc when the atom compile optimizations are used.

---

 src/mesa/drivers/dri/r200/r200_cmdbuf.c |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/mesa/drivers/dri/r200/r200_cmdbuf.c b/src/mesa/drivers/dri/r200/r200_cmdbuf.c
index 931a9ec..db5cc16 100644
--- a/src/mesa/drivers/dri/r200/r200_cmdbuf.c
+++ b/src/mesa/drivers/dri/r200/r200_cmdbuf.c
@@ -47,9 +47,9 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
  */
 #define insert_at_tail_if(atom_list, atom) \
    do { \
-      struct radeon_state_atom* __atom = (atom); \
-      if (__atom->check) \
-	 insert_at_tail((atom_list), __atom); \
+      struct radeon_state_atom* current_atom = (atom); \
+      if (current__atom->check) \
+	 insert_at_tail((atom_list), current_atom); \
    } while(0)
 
 void r200SetUpAtomList( r200ContextPtr rmesa )




More information about the mesa-commit mailing list