[Mesa-dev] dri loader ABI change between mesa 7.7 and 7.8

Brian Paul brianp at vmware.com
Mon Jun 21 16:23:25 PDT 2010

Julien Cristau wrote:
> Hi,
> it seems that the dri loader ABI changed between mesa 7.7 and 7.8.
> Drivers from 7.7 reference a _glapi_set_warning_func symbol which
> doesn't seem to be exported by the 7.8 libGL, so the new libGL can't
> load the old drivers.  Was this change intentional?  What is the
> intended stability of that interface?

This was fixed with commit f1381880a8e0e0cdd96c4c725ff35a28b250b09d 
and should be in Mesa 7.8.2


More information about the mesa-dev mailing list