[Mesa-dev] [PATCH v2 2/2] i965 Gen6: Implement gl_ClipVertex.

Ian Romanick idr at freedesktop.org
Tue Oct 4 12:20:20 PDT 2011

On 10/04/2011 10:49 AM, Paul Berry wrote:
> On 4 October 2011 10:32, Chad Versace <chad at chad-versace.us
> <mailto:chad at chad-versace.us>> wrote:
>     Hash: SHA1
>     Overall, the patch looks good, but I'm going to take the bikeshed bait.
>     Symbols of form GLxxx and constants of form GL_XXX should be
>     reserved for
>     those defined in the GL headers. If I encountered the symbol GLclipplane
>     in Mesa, I would confidently, yet incorrectly, assume the symbol was
>     defined in some GL extension of which I was unaware.

You mean like GLstencil and GLbitfield64? :)

>     Typically, when we wish a symbol name to be closely related to it GL
>     analogue,
>     we use one of the following naming schemes:
>             fuctions: _mesa_CamelCaps, intel_no_caps
>             struct: gl_no_caps
>             enums: gl_no_caps
>             constants: MESA_XXX
>     For examples:
>             _mesa_BindFramebufferEXT(), intel_bind_framebuffer()
>             struct gl_framebuffer
>             enum gl_format
>             MESA_FORMAT_RGBA8888
> Ok, I'm fine with this.  Unless someone has a better suggestion, I
> propose renaming "GLclipplane" to "gl_clip_plane".  Would that address
> your concerns, Chad?

That would work for me.

More information about the mesa-dev mailing list