[Mesa-dev] [PATCH 3/6] i965/fs: Add set_sechalf() method.

Francisco Jerez currojerez at riseup.net
Fri May 15 14:46:35 PDT 2015


Matt Turner <mattst88 at gmail.com> writes:

> Used in the next commit.
> ---
>  src/mesa/drivers/dri/i965/brw_ir_fs.h | 10 ++++++++++
>  1 file changed, 10 insertions(+)
>
> diff --git a/src/mesa/drivers/dri/i965/brw_ir_fs.h b/src/mesa/drivers/dri/i965/brw_ir_fs.h
> index 7ac7ff8..a79713c 100644
> --- a/src/mesa/drivers/dri/i965/brw_ir_fs.h
> +++ b/src/mesa/drivers/dri/i965/brw_ir_fs.h
> @@ -261,4 +261,14 @@ public:
>     bool pi_noperspective:1;   /**< Pixel interpolator noperspective flag */
>  };
>  
> +/**
> + * Set second-half quarter control on \p inst.
> + */
> +static inline fs_inst *
> +set_sechalf(fs_inst *inst)
> +{
> +   inst->force_sechalf = true;
> +   return inst;
> +}
> +

Hey Matt, just a quick request that would make this helper more useful:
Can we make this take the half as an index integer argument (and maybe
rename it to set_half), just like the half() register helper does?  That
would allow using it in a loop, for instance.

Also the subject line calls it a method while it is a stand-alone
function.  With that fixed:
Reviewed-by: Francisco Jerez <currojerez at riseup.net>

>  #endif
> -- 
> 2.3.6
>
> _______________________________________________
> mesa-dev mailing list
> mesa-dev at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/mesa-dev
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 212 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20150516/685d80dc/attachment.sig>


More information about the mesa-dev mailing list