<div dir="ltr">On 30 July 2013 11:08, Kenneth Graunke <span dir="ltr"><<a href="mailto:kenneth@whitecape.org" target="_blank">kenneth@whitecape.org</a>></span> wrote:<br><div class="gmail_extra"><div class="gmail_quote">
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="im">On 07/28/2013 11:03 PM, Paul Berry wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
From: Bryan Cain <<a href="mailto:bryancain3@gmail.com" target="_blank">bryancain3@gmail.com</a>><br>
<br>
These correspond to the EmitVertex and EndPrimitive functions in GLSL.<br>
<br>
v2 (Paul Berry <<a href="mailto:stereotype441@gmail.com" target="_blank">stereotype441@gmail.com</a>>): Add stub implementations of<br>
new pure visitor functions to i965's vec4_visitor and fs_visitor<br>
classes.<br>
</blockquote>
<br></div>
I would prefer to see these called:<br>
<br>
ir_emit_vertex<br>
ir_end_primitive<br>
<br>
The GLSL constructs are called EmitVertex and EndPrimitive, and so the obvious conversion from CamelCase to lowercase_with_underscores would result in ir_emit_vertex/ir_end_<u></u>primitive.<br>
<br>
I hate to make that suggestion, since it means a lot of pointless churn, but...somehow ir_emitvertex just bothers me every time I see it.</blockquote><div><br></div><div>Yeah, I agree with you.  Consistency is good, and now is the best time to achieve it since the series hasn't landed yet.  I'll make the changes you suggest.<br>
</div></div></div></div>