<div dir="ltr">On 26 November 2013 00:02, Francisco Jerez <span dir="ltr"><<a href="mailto:currojerez@riseup.net" target="_blank">currojerez@riseup.net</a>></span> wrote:<br><div class="gmail_extra"><div class="gmail_quote">
<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><br>
+    * ARB_shader_image_load_store qualifiers.<br>
+    */<br>
+   struct {<br>
+      bool read_only;<br>
+      bool write_only;<br></blockquote><div><br>It's hard to come up with a good naming convention for read_only and write_only--should they have underscores (like the GLenum values GL_READ_ONLY and GL_WRITE_ONLY) or not (like the GLSL keywords readonly and writeonly)?  I think you've made a reasonable choice to standardize on always using underscores.  However, I would appreciate a short comment next to "read_only" and "write_only" to indicate that the corresponding GLSL keywords are "readonly" and "writeonly".<br>
<br></div><div>With that change, the patch is:<br><br>Reviewed-by: Paul Berry <<a href="mailto:stereotype441@gmail.com">stereotype441@gmail.com</a>><br></div><br></div></div></div>