<div dir="ltr"><p dir="ltr"><br>
On Sep 3, 2015 1:49 AM, "Kenneth Graunke" <<a href="mailto:kenneth@whitecape.org" target="_blank">kenneth@whitecape.org</a>> wrote:<br>
><br>
> This patch also introduces a lowering pass to convert the simple GS<br>
> intrinsics to the new ones.  See the comments above that for the<br>
> rationale behind the new intrinsics.<br>
><br>
> This should be useful for i965; it's a generic enough mechanism that I<br>
> could see other drivers potentially using it as well, so I don't feel<br>
> too bad about putting it in the generic code.<br>
><br>
> Signed-off-by: Kenneth Graunke <<a href="mailto:kenneth@whitecape.org" target="_blank">kenneth@whitecape.org</a>><br>
> ---<br>
>  src/glsl/Makefile.sources              |   1 +<br>
>  src/glsl/nir/nir.h                     |   2 +<br>
>  src/glsl/nir/nir_intrinsics.h          |  21 ++++<br>
>  src/glsl/nir/nir_lower_gs_intrinsics.c | 214 +++++++++++++++++++++++++++++++++<br>
>  4 files changed, 238 insertions(+)<br>
>  create mode 100644 src/glsl/nir/nir_lower_gs_intrinsics.c<br>
><br>
> diff --git a/src/glsl/Makefile.sources b/src/glsl/Makefile.sources<br>
> index c422303..ae2e3e1 100644<br>
> --- a/src/glsl/Makefile.sources<br>
> +++ b/src/glsl/Makefile.sources<br>
> @@ -36,6 +36,7 @@ NIR_FILES = \<br>
>         nir/nir_lower_alu_to_scalar.c \<br>
>         nir/nir_lower_atomics.c \<br>
>         nir/nir_lower_global_vars_to_local.c \<br>
> +       nir/nir_lower_gs_intrinsics.c \<br>
>         nir/nir_lower_load_const_to_scalar.c \<br>
>         nir/nir_lower_locals_to_regs.c \<br>
>         nir/nir_lower_idiv.c \<br>
> diff --git a/src/glsl/nir/nir.h b/src/glsl/nir/nir.h<br>
> index 570a33c..13f123f 100644<br>
> --- a/src/glsl/nir/nir.h<br>
> +++ b/src/glsl/nir/nir.h<br>
> @@ -1809,6 +1809,8 @@ void nir_lower_idiv(nir_shader *shader);<br>
>  void nir_lower_atomics(nir_shader *shader);<br>
>  void nir_lower_to_source_mods(nir_shader *shader);<br>
><br>
> +void nir_lower_gs_intrinsics(nir_shader *shader);<br>
> +<br>
>  void nir_normalize_cubemap_coords(nir_shader *shader);<br>
><br>
>  void nir_live_variables_impl(nir_function_impl *impl);<br>
> diff --git a/src/glsl/nir/nir_intrinsics.h b/src/glsl/nir/nir_intrinsics.h<br>
> index ed309b6..bcfe70d 100644<br>
> --- a/src/glsl/nir/nir_intrinsics.h<br>
> +++ b/src/glsl/nir/nir_intrinsics.h<br>
> @@ -79,9 +79,30 @@ BARRIER(memory_barrier)<br>
>  /** A conditional discard, with a single boolean source. */<br>
>  INTRINSIC(discard_if, 1, ARR(1), false, 0, 0, 0, 0)<br>
><br>
> +/**<br>
> + * Basic Geometry Shader intrinsics.<br>
> + *<br>
> + * emit_vertex implements GLSL's EmitStreamVertex() built-in.  It takes a single<br>
> + * index, which is the stream ID to write to.<br>
> + *<br>
> + * end_primitive implements GLSL's EndPrimitive() built-in.<br>
> + */<br>
>  INTRINSIC(emit_vertex,   0, ARR(), false, 0, 0, 1, 0)<br>
>  INTRINSIC(end_primitive, 0, ARR(), false, 0, 0, 1, 0)<br>
><br>
> +/**<br>
> + * Geometry Shader intrinsics with a vertex count.<br>
> + *<br>
> + * Alternatively, drivers may implement these intrinsics, and use<br>
> + * nir_lower_gs_intrinsics() to convert from the basic intrinsics.<br>
> + *<br>
> + * These maintain a count of the number of vertices emitted, as an additional<br>
> + * unsigned integer source.<br>
> + */<br>
> +INTRINSIC(emit_vertex_with_counter, 1, ARR(1), false, 0, 0, 1, 0)<br>
> +INTRINSIC(end_primitive_with_counter, 1, ARR(1), false, 0, 0, 1, 0)<br>
> +INTRINSIC(set_vertex_count, 1, ARR(1), false, 0, 0, 0, 0)<br>
> +<br>
>  /*<br>
>   * Atomic counters<br>
>   *<br>
> diff --git a/src/glsl/nir/nir_lower_gs_intrinsics.c b/src/glsl/nir/nir_lower_gs_intrinsics.c<br>
> new file mode 100644<br>
> index 0000000..b866d87<br>
> --- /dev/null<br>
> +++ b/src/glsl/nir/nir_lower_gs_intrinsics.c<br>
> @@ -0,0 +1,214 @@<br>
> +/*<br>
> + * Copyright © 2015 Intel Corporation<br>
> + *<br>
> + * Permission is hereby granted, free of charge, to any person obtaining a<br>
> + * copy of this software and associated documentation files (the "Software"),<br>
> + * to deal in the Software without restriction, including without limitation<br>
> + * the rights to use, copy, modify, merge, publish, distribute, sublicense,<br>
> + * and/or sell copies of the Software, and to permit persons to whom the<br>
> + * Software is furnished to do so, subject to the following conditions:<br>
> + *<br>
> + * The above copyright notice and this permission notice (including the next<br>
> + * paragraph) shall be included in all copies or substantial portions of the<br>
> + * Software.<br>
> + *<br>
> + * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR<br>
> + * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,<br>
> + * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL<br>
> + * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER<br>
> + * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING<br>
> + * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS<br>
> + * IN THE SOFTWARE.<br>
> + *<br>
> + * Authors:<br>
> + *    Kenneth Graunke <<a href="mailto:kenneth@whitecape.org" target="_blank">kenneth@whitecape.org</a>><br>
> + */<br>
> +<br>
> +#include "nir.h"<br>
> +#include "nir_builder.h"<br>
> +<br>
> +/**<br>
> + * \file nir_lower_gs_intrinsics.c<br>
> + *<br>
> + * Geometry Shaders can call EmitVertex()/EmitStreamVertex() to output an<br>
> + * arbitrary number of vertices.  However, the shader must declare the maximum<br>
> + * number of vertices that it will ever output - further attempts to emit<br>
> + * vertices result in undefined behavior according to the GLSL specification.<br>
> + *<br>
> + * Drivers might use this maximum number of vertices to allocate enough space<br>
> + * to hold the geometry shader's output.  Some drivers (such as i965) need to<br>
> + * implement "safety checks" which ensure that the shader hasn't emitted too<br>
> + * many vertices, to avoid overflowing that space and trashing other memory.<br>
> + *<br>
> + * The count of emitted vertices can also be useful in buffer offset<br>
> + * calculations, so drivers know where to write the GS output.<br>
> + *<br>
> + * However, for simple geometry shaders that emit a statically determinable<br>
> + * number of vertices, this extra bookkeeping is unnecessary and inefficient.<br>
> + * By tracking the vertex count in NIR, we allow constant folding/propagation<br>
> + * and dead control flow optimizations to eliminate most of it where possible.<br>
> + *<br>
> + * This pass introduces a new global variable which stores the current vertex<br>
> + * count (initialized to 0), and converts emit_vertex/end_primitive intrinsics<br>
> + * to their *_with_counter variants.  emit_vertex is also wrapped in a safety<br>
> + * check to avoid buffer overflows.  Finally, it adds a set_vertex_count<br>
> + * intrinsic at the end of the program, informing the driver of the final<br>
> + * vertex count.<br>
> + */<br>
> +<br>
> +struct state {<br>
> +   nir_builder *builder;<br>
> +   nir_variable *vertex_count;<br>
> +};<br>
> +<br>
> +/**<br>
> + * Replace emit_vertex intrinsics with:<br>
> + *<br>
> + * if (vertex_count < max_vertices) {<br>
> + *    emit_vertex_with_counter vertex_count ...<br>
> + *    vertex_count += 1<br>
> + * }<br>
> + */<br>
> +static void<br>
> +rewrite_emit_vertex(nir_intrinsic_instr *intrin, struct state *state)</p>
<p dir="ltr">I'm inclined to rename "intrin" to "emit". It may be easier to track with the lowering code.</p>
<p dir="ltr">> +{<br>
> +   nir_builder *b = state->builder;<br>
> +   nir_variable *vertex_count_var = state->vertex_count;<br>
> +   nir_instr *instr = &intrin->instr;</p>
<p dir="ltr">Please get rid of these last two aliases ("b" is fine). They don't make things much shorter and, IMHO, they actually make readability worse because there are multiple names for things.</p>
<p dir="ltr">> +<br>
> +   /* Load the vertex count */<br>
> +   b->cursor = nir_before_instr(instr);<br>
> +   nir_ssa_def *count = nir_load_var(b, vertex_count_var);<br>
> +<br>
> +   nir_ssa_def *max_vertices = nir_imm_int(b, b->shader->gs.vertices_out);<br>
> +<br>
> +   /* Create: if (vertex_count < max_vertices) */<br>
> +   nir_if *if_stmt = nir_if_create(b->shader);<br>
> +   if_stmt->condition = nir_src_for_ssa(nir_ilt(b, count, max_vertices));<br>
> +<br>
> +   /* Replace the instruction.  The new if statement needs to be hooked up<br>
> +    * to the control flow graph before we start inserting instructions in it.<br>
> +    */<br>
> +   nir_builder_cf_insert(b, &if_stmt->cf_node);<br>
> +   nir_instr_remove(instr);</p>
<p dir="ltr">I think we usually delete the instruction at the end.  Not that it matters but it does make it more clear that you don't have dangling cursor problems.</p>
<p dir="ltr">> +<br>
> +   /* Fill out the new then-block */<br>
> +   b->cursor = nir_after_cf_list(&if_stmt->then_list);<br>
> +<br>
> +   nir_intrinsic_instr *lowered =<br>
> +      nir_intrinsic_instr_create(b->shader,<br>
> +                                 nir_intrinsic_emit_vertex_with_counter);<br>
> +   lowered->const_index[0] = intrin->const_index[0];<br>
> +   lowered->src[0] = nir_src_for_ssa(count);<br>
> +   nir_builder_instr_insert(b, &lowered->instr);<br>
> +<br>
> +   /* Increment the vertex count by 1 */<br>
> +   nir_store_var(b, vertex_count_var, nir_iadd(b, count, nir_imm_int(b, 1)));<br>
> +}<br>
> +<br>
> +/**<br>
> + * Replace end_primitive with end_primitive_with_counter.<br>
> + */<br>
> +static void<br>
> +rewrite_end_primitive(nir_intrinsic_instr *intrin, struct state *state)<br>
> +{<br>
> +   nir_builder *b = state->builder;<br>
> +<br>
> +   b->cursor = nir_before_instr(&intrin->instr);<br>
> +   nir_ssa_def *count = nir_load_var(b, state->vertex_count);<br>
> +<br>
> +   nir_intrinsic_instr *lowered =<br>
> +      nir_intrinsic_instr_create(b->shader,<br>
> +                                 nir_intrinsic_end_primitive_with_counter);<br>
> +   lowered->const_index[0] = intrin->const_index[0];<br>
> +   lowered->src[0] = nir_src_for_ssa(count);<br>
> +   nir_builder_instr_insert(b, &lowered->instr);<br>
> +<br>
> +   nir_instr_remove(&intrin->instr);<br>
> +}<br>
> +<br>
> +static bool<br>
> +rewrite_intrinsics(nir_block *block, void *closure)<br>
> +{<br>
> +   struct state *state = closure;<br>
> +<br>
> +   nir_foreach_instr_safe(block, instr) {<br>
> +      if (instr->type != nir_instr_type_intrinsic)<br>
> +         continue;<br>
> +<br>
> +      nir_intrinsic_instr *intrin = nir_instr_as_intrinsic(instr);<br>
> +      switch (intrin->intrinsic) {<br>
> +      case nir_intrinsic_emit_vertex:<br>
> +         rewrite_emit_vertex(intrin, state);<br>
> +         break;<br>
> +      case nir_intrinsic_end_primitive:<br>
> +         rewrite_end_primitive(intrin, state);<br>
> +         break;<br>
> +      default:<br>
> +         /* not interesting; skip this */<br>
> +         break;<br>
> +      }<br>
> +   }<br>
> +<br>
> +   return true;<br>
> +}<br>
> +<br>
> +/**<br>
> + * Add a set_vertex_count intrinsic at the end of the program<br>
> + * (representing the final vertex count).<br>
> + */<br>
> +static void<br>
> +append_set_vertex_count(nir_block *end_block, struct state *state)<br>
> +{<br>
> +   nir_variable *vertex_count_var = state->vertex_count;<br>
> +   nir_builder *b = state->builder;<br>
> +   nir_shader *shader = state->builder->shader;<br>
> +<br>
> +   /* Insert the new intrinsic in all of the predecessors of the end block,<br>
> +    * but before any jump instructions (return).<br>
> +    */<br>
> +   struct set_entry *entry;<br>
> +   set_foreach(end_block->predecessors, entry) {<br>
> +      nir_block *pred = (nir_block *) entry->key;<br>
> +      b->cursor = nir_after_block(pred);</p><p>Technically, this should be after_block_before_jump().  We should probably just land the patch that adds that.  I'll send them out.<br></p><p dir="ltr">
> +<br>
> +      nir_ssa_def *count = nir_load_var(b, vertex_count_var);<br>
> +<br>
> +      nir_intrinsic_instr *set_vertex_count =<br>
> +         nir_intrinsic_instr_create(shader, nir_intrinsic_set_vertex_count);<br>
> +      set_vertex_count->src[0] = nir_src_for_ssa(count);<br>
> +<br>
> +      nir_builder_instr_insert(b, &set_vertex_count->instr);<br>
> +   }<br>
> +}<br>
> +<br>
> +void<br>
> +nir_lower_gs_intrinsics(nir_shader *shader)<br>
> +{<br>
> +   struct state state;<br>
> +<br>
> +   /* Create the counter variable */<br>
> +   nir_variable *var = rzalloc(shader, nir_variable);<br>
> +   var->data.mode = nir_var_global;<br>
> +   var->type = glsl_uint_type();<br>
> +   var->name = "vertex_count";<br>
> +   var->constant_initializer = rzalloc(shader, nir_constant); /* initialize to 0 */<br>
> +<br>
> +   exec_list_push_tail(&shader->globals, &var->node);<br>
> +   state.vertex_count = var;<br>
> +<br>
> +   nir_foreach_overload(shader, overload) {<br>
> +      if (overload->impl) {<br>
> +         nir_builder b;<br>
> +         nir_builder_init(&b, overload->impl);<br>
> +         state.builder = &b;<br>
> +<br>
> +         nir_foreach_block(overload->impl, rewrite_intrinsics, &state);<br>
> +<br>
> +         /* This only works because we have a single main() function. */</p><p>Then why don't you predicate it on name == "main" or something?  Really, we should probably just add an is_entrypoint bool to nir_function_impl and switch on that.  Another option would be to make this take a function impl instead of a shader and trust in function inlining (maybe even assert no function calls).<br></p><p dir="ltr">
> +         append_set_vertex_count(overload->impl->end_block, &state);<br>
> +<br>
> +         nir_metadata_preserve(overload->impl, 0);<br>
> +      }<br>
> +   }<br>
> +}<br>
> --<br>
> 2.5.0<br>
><br>
> _______________________________________________<br>
> mesa-dev mailing list<br>
> <a href="mailto:mesa-dev@lists.freedesktop.org" target="_blank">mesa-dev@lists.freedesktop.org</a><br>
> <a href="http://lists.freedesktop.org/mailman/listinfo/mesa-dev" target="_blank">http://lists.freedesktop.org/mailman/listinfo/mesa-dev</a><br>
</p>
</div>