<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Oct 22, 2015 at 11:08 AM, Chad Versace <span dir="ltr"><<a href="mailto:chad.versace@intel.com" target="_blank">chad.versace@intel.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="HOEnZb"><div class="h5">On Thu 22 Oct 2015, Emil Velikov wrote:<br>
> On 19 October 2015 at 23:36, Nanley Chery <<a href="mailto:nanleychery@gmail.com">nanleychery@gmail.com</a>> wrote:<br>
> > From: Nanley Chery <<a href="mailto:nanley.g.chery@intel.com">nanley.g.chery@intel.com</a>><br>
> ><br>
> > Create a function which determines if an extension is supported in the<br>
> > current context.<br>
> ><br>
> > Signed-off-by: Nanley Chery <<a href="mailto:nanley.g.chery@intel.com">nanley.g.chery@intel.com</a>><br>
> > ---<br>
> >  src/mesa/main/extensions.c | 17 +++++++++++++++++<br>
> >  1 file changed, 17 insertions(+)<br>
> ><br>
> > diff --git a/src/mesa/main/extensions.c b/src/mesa/main/extensions.c<br>
> > index 390e026..7137bc9 100644<br>
> > --- a/src/mesa/main/extensions.c<br>
> > +++ b/src/mesa/main/extensions.c<br>
> > @@ -423,6 +423,23 @@ typedef unsigned short extension_index;<br>
> ><br>
> ><br>
> >  /**<br>
> > + * Given an extension enum, return whether or not the extension is supported<br>
> > + * dependent on the following factors:<br>
> > + * There's driver support and the OpenGL/ES version is at least that<br>
> > + * specified in the extension_table.<br>
> > + */<br>
> > +static inline bool<br>
> > +_mesa_extension_supported(const struct gl_context *ctx, extension_index ei)<br>
> > +{<br>
> > +   const bool *base = (bool *) &ctx->Extensions;<br>
> > +   const struct extension *i = extension_table + ei;<br>
> > +   const uint8_t api_set = 1 << ctx->API;<br>
> > +   return (i->api_set & api_set) &&<br>
> > +          (ctx->Version >= i->version[ctx->API]) &&<br>
> > +          base[i->offset];<br>
> Bikeshed: I realise that you're copying most of these, but wouldn't it<br>
> be better if we use more common/intuitive variable names ?<br>
><br>
> ei -> i or idx<br>
> i -> ext<br>
<br>
</div></div>I second Emil's suggestion.<br></blockquote><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
Please insert an empty line between the block of variable declarations<br>
and the return statement.<br>
<br>
Also, it improves the readability if you rename the local variable<br>
'api_set' to 'api_bit', because it's not really a set. It's just one<br>
bit.<br>
</blockquote></div><br></div><div class="gmail_extra">I'll incorporate both changes.<br></div></div>