[Nouveau] unable to compile xf86-video-nouveau

Renato Caldas seventhguardian at gmail.com
Wed Jul 9 03:51:27 PDT 2008

On Wed, Jul 9, 2008 at 11:33 AM, Renato Caldas
<seventhguardian at gmail.com> wrote:
> On Wed, Jul 9, 2008 at 3:43 AM, Bob Gleitsmann <rjgleits at bellsouth.net> wrote:
>> Greetings,
>> After the modesetting commit, I have been unable to compile
>> xf86-video-nouveau. The git site for drm given on the wiki page does not get
>> the proper xf86drmMode.h, etc. I noted that libdrm git has over 100 branches
>> and I really don't want to try all of them. Fedora 9 has a patch of the
>> libdrm source rpm that includes an earlier version of xf86drmMode.h but it's
>> now out of date. I would like to follow along in the development of nouveau
>> as I have a GeForce 6800 GTO.
>> Your kind help would be appreciated.
> You're probably using a modesetting drm branch. The easy solution is
> to switch to the plain drm branch.
> If you really want to stick to the drm modesetting branch then you
> AFAICT need git xorg, or some workarounds that make it compile for
> non-git xorg.
> Patch attached, but note that this is only a workaround. You can
> commit it to your local nouveau repo and then git-rebase it after
> git-fetching (I hope you know how to do that ;) .

Ah, the problem is a different one, and just realized it was there.
You need to stick to plain drm for now. Some changes were made to it
that are still not part of the modesetting branch.


> Good luck,
>  Renato Caldas
>> Best Wishes,
>> Bob Gleitsmann
>> _______________________________________________
>> Nouveau mailing list
>> Nouveau at lists.freedesktop.org
>> http://lists.freedesktop.org/mailman/listinfo/nouveau

More information about the Nouveau mailing list