[Nouveau] [PATCH 0/4] nvfx: rework render temps code and fixes

Marek Olšák maraeo at gmail.com
Mon Jan 16 17:18:04 PST 2012

HI everyone,

first, I am not subscribed to the nouveau mailing list, so please CC
me if you need anything.

I pushed the whole series because there was no feedback on mesa-dev
for like 5 days. If you want to revert it, just let me know and I'll
do it.


On Mon, Jan 16, 2012 at 5:33 PM, Lucas Stach <dev at lynxeye.de> wrote:
> I seems Marek has just accidentally pushed the whole series. So we have
> a bit of a difficult situation here. I'm not sure if we should just
> revert or if we can leave the patches upstream.
> I'm aware that this patches haven't received much testing by others than
> me and that a review of the code is still oustanding, but I like to
> stress the point that these patches are rigorously tested by me and are
> relatively low risk.
> Patrice your report of this patchset not working did surprise me, so can
> you please make sure those patches are really the cause for your issues?
> I heard reports that nv3x is not working properly with mesa/master for
> some time. I tried to reproduce the problem on my nv49 setup and I don't
> see any issues besides the well known vertex corruption, which is most
> likely due to some missing reloc somewhere or the like.
> Regards,
> Lucas
> Am Montag, den 16.01.2012, 01:09 +0100 schrieb Lucas Stach:
>> Am Samstag, den 14.01.2012, 13:14 +0100 schrieb Patrice Mandin:
>> > Hello,
>> >
>> > I just tried on my NV34 the whole series. Here is what I noticed:
>> Thanks for testing. Although now after some discussion it seems unlikely
>> that we will see much of this in nvfx it really helps me to decide if i
>> can go this way in the rewrite driver.
>> >
>> > - Seems rendering is a bit slower (in ioquake3, in the first map q3dm0,
>> > rendering the mirror and the portal causes more audio stuttering) but
>> > it it just my feeling.
>> Without the render temps we should actually do less work, rather than
>> more, so you shouldn't see any slowdown from this. Maybe we are hitting
>> a slow path elsewhere in the driver (like a cpu copy of a gpu only
>> surface).
>> >
>> > - ut2004demo hangs at start (display just one frame in the nvidia
>> > licence plate part), but the system does not crash, and the game can be
>> > killed.
>> >
>> > Do you want me to check which of your patches makes ut2004 hanging?
>> >
>> No, please just check dmesg, to see if you get any errors there. I will
>> try to reproduce with my setup.
>> Thanks,
>> Lucas
>> _______________________________________________
>> Nouveau mailing list
>> Nouveau at lists.freedesktop.org
>> http://lists.freedesktop.org/mailman/listinfo/nouveau

More information about the Nouveau mailing list