[packagekit] backend 0.4.x and 0.5.x compatibility
Anders F Björklund
afb at algonet.se
Thu Aug 27 01:23:35 PDT 2009
Richard Hughes wrote:
>> I develop pisi backend on 0.4.9. I want backend is compatible with
>> 0.5.x. But i have some problem.
> Right, you have to understand that in 0.5.x versions we're using a new
> security framework (PolicyKit1, rather than PolicyKit) which allows us
> to do some cool things, but also means the methods have to be more
Since PolicyKitOne isn't released, and maybe won't be available
for a long time since it requires (pre-release) glib >= 2.21.4,
would it be a good idea to have backends support both versions ?
(support both of PackageKit 0.4.x and PackageKit 0.5.x that is)
>> how can i write compatible backend between 0.4.9 and 0.5.x?
> I don't think you can -- well, you could fudge it and share a
> common file with:
> #if PK_CHECK_VERSION(0,5,0)
> around the only_trusted stuff. By that's a bit of a bodge.
Is there a list of changes between the API versions somewhere ?
(maybe one can still share the same spawned scripted backend...)
More information about the PackageKit