[packagekit] backend 0.4.x and 0.5.x compatibility
hughsient at gmail.com
Thu Aug 27 02:36:16 PDT 2009
2009/8/27 Anders F Björklund <afb at algonet.se>:
> Since PolicyKitOne isn't released, and maybe won't be available
> for a long time since it requires (pre-release) glib >= 2.21.4,
Sure it it -- it's had quite a few releases. Just because stuff
depends on unstable releases of libraries, doesn't mean it's not been
released. I was playing with it in Fedora 11 and now use it every day
using F12 alpha.
> would it be a good idea to have backends support both versions ?
> (support both of PackageKit 0.4.x and PackageKit 0.5.x that is)
I still support 0.4.x and 0.5.x, but 0.4.x is is feature freeze and
bug-fix only mode. 0.5.x is where all the cool new stuff happens.
0.4.x will be deprecated when 0.6.0 is released.
> Is there a list of changes between the API versions somewhere ?
git diff PACKAGEKIT_0_4_X..master src/org.freedesktop.PackageKit*.xml
> (maybe one can still share the same spawned scripted backend...)
I don't think that's a really good idea, I mean, the only_trusted
stuff is very important in 0.5.x.
More information about the PackageKit