[packagekit] API changes

Fabio Erculiani lxnay at sabayon.org
Fri Feb 26 02:45:23 PST 2010

On Wed, Feb 24, 2010 at 9:56 PM, Daniel Nicoletti
<dantti85-pk at yahoo.com.br> wrote:
>> On 24 February 2010 20:19, Daniel Nicoletti  wrote:
>> > Richard,
>> > I've just commited the autoremove of simulateRemove()
>> Could you do lib/packagekit-glib2 as well please. Thanks.
> Oh, I thought I did change it...
>> > Can I start the remove_needed change?
>> Can you summarise (for the list) why this API change is being done
>> please. Thanks.
> Installing/updating packages in APT (and some other backends) might
> emit packages to be removed, so you might want to allow people to
> installPackages on your computer but not to remove. In this case
> adding a bool remove_needed to both methods allows PK
> to issue Polkit and ask for the remove action just as we do
> for only trusted.

Are there function signature changes? If so, could you please
thorougly explain the differences?
I am interested in adding this to my backends.

Fabio Erculiani

More information about the PackageKit mailing list