[packagekit] [PATCH] Add support for Plasma service lookup
hughsient at gmail.com
Mon Jun 20 01:31:15 PDT 2011
On 20 June 2011 05:04, Kevin Kofler <kevin.kofler at chello.at> wrote:
> The attached patches implement the required PackageKit support, both in the
> core and in the frontends. I have tested that those patches compile. I
> haven't done any runtime testing yet because I have to write the Plasma-side
> code first to test this properly.
> * packagekit-plasma.patch is the patch for PackageKit itself. It adds a new
> enum member called PK_PROVIDES_ENUM_PLASMA_SERVICE and implements it in the
> yum and zif backends by looking up the RPM Provides generated by this
> All the frontend patches depend on this patch.
I've committed this code, thanks.
> * gnome-packagekit-plasma.patch is for gnome-packagekit. I am least sure
> about this one:
> - Do we want this feature in gnome-packagekit at all?
Right, I think this isn't the kind of thing we want -- this is kde
specific. I think it makes a lot more sense to have a:
I've been asked by the haskell community for essentially the same
thing, and whilst enums in PackageKit are cheap, there's quite a lot
of additional code in the frontend for each thing. I thing it's fine
to add specific translations in the title, but not to keep adding new
DBus interface members.
As an aside, if I had known all the different provide types people
would want to have used, I would have used InstallResources from the
Could you please fix the gnome-packagekit patch to be
InstallResources() rather than InstallPlasmaResources() and then I'll
do a proper review. It's likely that after InstallResources is added,
then I can nuke a lot of duplicated code from gnome-packagekit.
More information about the PackageKit