<div dir="ltr"><div><div>Ah, that makes sense.<br><br></div><div>I have no further complaints and I'm not sure what the most approriate tag is, since I'm not a CL expert. I'm guessing acked-by, but feel free to use something else if it's more appropriate.<br>
Acked-by: Dylan Baker <<a href="mailto:baker.dylan.c@gmail.com">baker.dylan.c@gmail.com</a>><br></div></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Thu, Aug 1, 2013 at 7:34 PM, Tom Stellard <span dir="ltr"><<a href="mailto:tom@stellard.net" target="_blank">tom@stellard.net</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On Wed, Jul 31, 2013 at 11:37:16PM -0700, Dylan Baker wrote:<br>
<br>
Hi Dylan,<br>
<br>
Thanks for your comments.<br>
<div class="im"><br>
> I have some python comments for you, they're mainly style type comments,<br>
> but some of them should help your code readability a lot.<br>
><br>
><br>
> On Wed, Jul 31, 2013 at 7:16 PM, Tom Stellard <<a href="mailto:tom@stellard.net">tom@stellard.net</a>> wrote:<br>
><br>
</div><div class="im">> > +VEC_SIZES = ['', '2', '4', '8', '16']<br>
> > +<br>
<br>
</div>...<br>
<div class="im"><br>
> I only see the one use of VEC_SIZES. Is there a reason element 0 is set to<br>
> '' and then you have an if statement here to change it to 1?<br>
><br>
<br>
</div>For the first element, 1 is the vector size, but '' is the string that<br>
needs to be appended to the type name. e.g.<br>
<br>
Type   Size<br>
-----  -----<br>
Float    1<br>
Float2   2<br>
Float4   4<br>
<br>
etc.<br>
<br>
I have addressed all you other comments in the attached patch.<br>
<span class="HOEnZb"><font color="#888888"><br>
-Tom<br>
</font></span><div class="HOEnZb"><div class="h5"><br>
> +        else:<br>
> > +            size = int(s)<br>
> > +        type_name = t + s<br>
> > +        f = begin_test(type_name, 'global')<br>
> > +        f.write( \<br>
> > +            '[test]\n' + \<br>
<br>
</div></div></blockquote></div><br></div>