pkg-config incorrect about libglib2 version when compiling gtkglext. but correct .pc file is there

Tom Parker palfrey at
Mon Dec 11 15:21:11 PST 2006

mitchell phillip Laks wrote:
> when i run ./configure for gtkglext all is fine until 
> checking for GLIB - version >= 2.0.0...
> *** 'pkg-config --modversion glib-2.0' returned 2.8.6, but GLIB (2.12.4)
> *** was found! If pkg-config was correct, then it is best
> *** to remove the old version of GLib. You may also be able to fix the error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
> *** /etc/ Make sure you have run ldconfig if that is
> *** required on your system.
> *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
> *** to point to the correct configuration files
> no
> configure: error: GLib 2.0 not found

Several things to try
1) Double-check the configure result - try running "pkg-config 
--modversion glib-2.0" directly. If that works, have a look at the 
config.log. Look just before the running of pkg-config, and see if 
configure is doing something odd.
3) If 1) doesn't work, check you've got the latest version of pkg-config 
installed. Latest version in sid is 0.21-1.
4) Check if you've got a glib-2.0.pc in /usr/local/pkgconfig. That would 
only be there if you've manually installed a version earlier. If it's 
there, delete it.
5) If you've installed the newest pkg-config, you can't find anything 
odd in the config.log, and you're sure that your environment is clean, 
install strace and run "strace pkg-config --modversion glib-2.0 
2>strace.log", then send the strace.log to this mailing list.

Tom Parker

More information about the pkg-config mailing list