PolicyKit 0.90 (pre-)release

Michael Biebl mbiebl at gmail.com
Sun Feb 1 13:16:06 PST 2009

Just curious: Why the rename from PolicyKit to polkit and
PolicyKit-gnome to polkit-gnome?

Would you like package descriptions to be updated and use the new names?

I also find it a bit ugly, that you tag a -1 to each and every
instance, even the D-Bus name.

Which brings me to my next concern: Apparently you want to have those
versions to be completely co-installable. What happens to already
granted permissions, will they be migrated, will we have two databases
which are completely out of sync?

This brings me to the question, why have co-installability at all? Why
does PolicyKit 0.90 not simply provide the the legacy backwards
compatible interfaces (libs and D-Bus) and simply imports and converts
the exising authentication db on first run.


Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

More information about the polkit-devel mailing list