<html>
<head>
<base href="https://bugs.freedesktop.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW --- - library should be thread-safe"
href="https://bugs.freedesktop.org/show_bug.cgi?id=50992#c57">Comment # 57</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW --- - library should be thread-safe"
href="https://bugs.freedesktop.org/show_bug.cgi?id=50992">bug 50992</a>
from <span class="vcard"><a class="email" href="mailto:Thomas.Freitag@alfa.de" title="Thomas Freitag <Thomas.Freitag@alfa.de>"> <span class="fn">Thomas Freitag</span></a>
</span></b>
<pre>(In reply to <a href="show_bug.cgi?id=50992#c54">comment #54</a>)
<span class="quote">> Some quick comments before i have a change to try it in 2 hours or so.
>
> The Annot.cc change does not belong here, right?</span >
Yes and no: I encountered that problem when I tried to get page rendering
thread safe and still had problems with it. BUT it's definitely safer to have
it in.
<span class="quote">>
> The recursion in Stream::addFilters does not belong here either i'd say, no?</span >
On contrary, it does belong here: Stream::addFilters can be called by
XRef::fetch and dictLookup can call XRef::fetch, and because the goo mutex
implementation does not know a recursive mutex we will run in a dead lock
without it.
<span class="quote">>
> GBool fCopy seems a bad name for something that decides if the xref is going
> to be copied, can we call it copyXRef? Same for fMT</span >
I'll change it.
<span class="quote">>
> Seems a bit weird leaving the non thread safe versions of getDocInfo and
> getDocInfoNF there, no? What's the use of them?</span >
I think I miss something. What do You mean?
<span class="quote">>
> In the qt4 frontend we don't need the incRef and decRef, that's poor's man
> solution. Users of qt4 frontend can put the Document * in a QSharedPointer
> to get the reference counting properly done (which by the way we should not
> need in Okular since the code ensure the PDF generator will only be deleted
> once all the threads have finished)</span >
I wasn't really lucky with it, so if not needed I'm glad to remove it again.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>