<html>
    <head>
      <base href="https://bugs.freedesktop.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW --- - Add support for printing to a Windows printer from pdftocairo"
   href="https://bugs.freedesktop.org/show_bug.cgi?id=79936#c32">Comment # 32</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW --- - Add support for printing to a Windows printer from pdftocairo"
   href="https://bugs.freedesktop.org/show_bug.cgi?id=79936">bug 79936</a>
              from <span class="vcard"><a class="email" href="mailto:carlosgc@gnome.org" title="Carlos Garcia Campos <carlosgc@gnome.org>"> <span class="fn">Carlos Garcia Campos</span></a>
</span></b>
        <pre>Comment on <span class=""><a href="attachment.cgi?id=103703" name="attach_103703" title="New patch version with many improvements">attachment 103703</a> <a href="attachment.cgi?id=103703&action=edit" title="New patch version with many improvements">[details]</a></span> <a href='page.cgi?id=splinter.html&bug=79936&attachment=103703'>[review]</a>
New patch version with many improvements

Review of <span class=""><a href="attachment.cgi?id=103703" name="attach_103703" title="New patch version with many improvements">attachment 103703</a> <a href="attachment.cgi?id=103703&action=edit" title="New patch version with many improvements">[details]</a></span> <a href='page.cgi?id=splinter.html&bug=79936&attachment=103703'>[review]</a>:
-----------------------------------------------------------------

::: utils/pdftocairo-win32.cc
@@ +1,3 @@
<span class="quote">> +#include <cairo-win32.h>
> +
> +static void win32GetFitToPageTransform(cairo_matrix_t *m)</span >

This is a private method of this file, I don't think we need to use the win32
prefix for this.

@@ +135,5 @@
<span class="quote">> +    }
> +  }
> +}
> +
> +static void win32BeginDocument(GooString *outputFileName, double w, double h)</span >

I would could this something like createPrintingSurface so that we don't need
to use the win32 prefix, this is called by beingDocument after all, not instead
of beginDocument. And I would make it return the surface instead.

@@ +137,5 @@
<span class="quote">> +}
> +
> +static void win32BeginDocument(GooString *outputFileName, double w, double h)
> +{
> +  if (!print)</span >

And this could be checked by the caller

@@ +140,5 @@
<span class="quote">> +{
> +  if (!print)
> +    return;
> +
> +  if (printer.getCString()[0] == 0)</span >

I think if (printer.getLength() == 0) is easier to read.

@@ +141,5 @@
<span class="quote">> +  if (!print)
> +    return;
> +
> +  if (printer.getCString()[0] == 0)
> +  {</span >

Move this to the previous line, for consistency with the rest of the code.

@@ +149,5 @@
<span class="quote">> +    GetDefaultPrinterA(devname, &szName);
> +    printer.Set(devname);
> +    gfree(devname);
> +  }
> +  char *cPrinter = printer.getCString();</span >

This should probably be const char *

@@ +154,5 @@
<span class="quote">> +
> +  //Query the size of the DEVMODE struct
> +  LONG szProp = DocumentPropertiesA(NULL, NULL, cPrinter, NULL, NULL, 0);
> +  if (szProp < 0)
> +  {</span >

Move this to the previous line

@@ +164,5 @@
<span class="quote">> +  devmode->dmSize = sizeof(DEVMODEA);
> +  devmode->dmSpecVersion = DM_SPECVERSION;
> +  //Load the current default configuration for the printer into devmode
> +  if (DocumentPropertiesA(NULL, NULL, cPrinter, devmode, NULL, DM_OUT_BUFFER) < 0)
> +  {</span >

Ditto.

@@ +170,5 @@
<span class="quote">> +    exit(99);
> +  }
> +  fillCommonPrinterOptions(devmode, w, h);
> +  fillPrinterOptions(devmode);
> +  HDC hdc = CreateDCA(NULL, cPrinter, NULL, devmode);</span >

I have no idea what DCA stands for, but maybe all previous code could be moved
to a helper function that initialize the printer and returns the HDC

@@ +173,5 @@
<span class="quote">> +  fillPrinterOptions(devmode);
> +  HDC hdc = CreateDCA(NULL, cPrinter, NULL, devmode);
> +  gfree(devmode);
> +  if (!hdc)
> +  {</span >

Ditto.

@@ +182,5 @@
<span class="quote">> +  DOCINFOA docinfo;
> +  memset(&docinfo, 0, sizeof(docinfo));
> +  docinfo.cbSize = sizeof(docinfo);
> +  if (outputFileName->cmp("fd://0") == 0)
> +  docinfo.lpszDocName = outputFileName->getCString();</span >

Fixed by Adrian in a follow up patch, it would be better to fix it here before
instead of landing a patch that break the build.

@@ +194,5 @@
<span class="quote">> +    
> +  surface = cairo_win32_printing_surface_create(hdc);
> +}
> +
> +static void win32BeginPage(double w, double h)</span >

Ah, I see all are static, but included in the other file. I would rather add a
header for the public methods, and include the header from pdtocairo instead.

::: utils/pdftocairo.cc
@@ +77,4 @@
<span class="quote">>  static GBool ps = gFalse;
>  static GBool eps = gFalse;
>  static GBool pdf = gFalse;
> +static GBool print = gFalse;</span >

I find this a bit confusing, because we also have printing variable. I would
use something like printingToWinPrinter or something like that

@@ +485,5 @@
<span class="quote">>        // shrink to fit
>        cairo_matrix_scale (m, scale, scale);
>      }
> +#ifdef CAIRO_HAS_WIN32_SURFACE
> +  win32GetFitToPageTransform(m);</span >

I see now this was actually "public", but again this is not the
getFitToPageTransform for win32, no? I would use a better name that express
what the function actually does</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>