[poppler] Running autogen.sh

Frank Meerkoetter frank at meerkoetter.org
Wed Feb 15 03:09:41 PST 2006


i try to work with the current poppler CVS but i've problems with the auto*
system. The configure script generated doesn't run.

Which version of autoconf/automake/libtool do i need to run autogen.sh?


Checking for automake >= 1.7...

  Testing automake-1.7... not found.
  Testing automake-1.8... not found.
  Testing automake-1.9... found 1.9.6
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal -I m4
autoreconf: configure.ac: tracing
autoreconf: running: libtoolize --copy
libtoolize: `config.guess' exists: use `--force' to overwrite
libtoolize: `config.sub' exists: use `--force' to overwrite
libtoolize: `ltmain.sh' exists: use `--force' to overwrite
autoreconf: running: /usr/local/bin/autoconf
autoreconf: running: /usr/local/bin/autoheader
autoreconf: running: automake --add-missing --copy --no-force
autoreconf: Leaving directory `.'
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking for fseek64... no
checking for ftell64... no
checking for libjpeg6b... no
checking for libjpeg... -ljpeg
./configure: line 23694: syntax error near unexpected token `FREETYPE,'
./configure: line 23694: `PKG_CHECK_MODULES(FREETYPE, freetype2,'

I run automake-1.9.6, libtool-1.5.22 and autoconf-2.59.


More information about the poppler mailing list