[poppler] Can't install Poppler

Pino Toscano pino at kde.org
Wed Apr 30 12:02:01 PDT 2008


> I wanted to use poppler (poppler-0.8.1 or the latest 0.8.2) with the
> Qt4.4 R.C, but I can't get it to compile.
> [...]
>   g++ -DHAVE_CONFIG_H -I. -I../.. -I../../poppler -I../..
> -I../../poppler -I../../qt -I/usr/local/Trolltech/Qt-4.4.0-rc1/include
> -Wall -Wno-write-strings -g -O2 -MT poppler-optcontent.lo -MD -MP -MF
> .deps/poppler-optcontent.Tpo -c poppler-optcontent.cc  -fPIC -DPIC -o
> .libs/poppler-optcontent.o
> Dans le fichier inclus à partir de poppler-optcontent.cc:426:
> poppler-optcontent.moc:10:25: erreur: qmetaobject.h : Aucun fichier ou
> répertoire de ce type

First, when pasting compiling error, do
$ LANG=C make
so we get some understandable output.

Second, make sure that the right moc is the first in $PATH; then
$ moc -v
should give you the right version.

Pino Toscano
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : http://lists.freedesktop.org/archives/poppler/attachments/20080430/258c02a2/attachment.pgp 

More information about the poppler mailing list