Thanks Albert to review this patch again.<br>Comments are inline:<br><br><div class="gmail_quote">On Sun, Jul 25, 2010 at 9:27 PM, Albert Astals Cid <span dir="ltr"><<a href="mailto:aacid@kde.org" target="_blank">aacid@kde.org</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">A Dimarts, 6 de juliol de 2010, leena chourey va escriure:<br>
> Dear Albert,<br>
<br>
Hi<br>
<div><br>
> Thanks for your response.<br>
><br>
> As discussed in the last mail, we have modified the patch so that:<br>
><br>
> - There is no behavioural change in pdftohtml -c <filename> means it<br>
> produces exactly the same output it did before.<br>
> - Defined new option as pdftohtml -s <filename> to generate a single<br>
> html file corresponding to a pdf file.<br>
><br>
> Please check and give your feedback if any further change is required.<br>
<br>
</div><span style="color: rgb(255, 0, 0);">You are using a variable you deleted (tmp) in this chunk of code</span><br style="color: rgb(255, 0, 0);">
<br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
***********************</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
delete tmp;</span><font color="#000000"></font></blockquote><div> <font color="#000000"><br>This (delete tmp) was from the original development code only, we didn't made changes regarding tmp.</font> I have checked, it is in the recent development version also.<br style="color: rgb(255, 0, 0);">
</div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<span style="color: rgb(255, 0, 0);">
- fprintf(pageFile,"%s\n<HTML>\</span><span style="color: rgb(255, 0, 0);">n<HEAD>\n<TITLE>Page %d</TITLE>\n\n",</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
- DOCTYPE, page);</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
+ if (!singleHtml)</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
+ fprintf(pageFile,"%s\n<HTML>\</span><span style="color: rgb(255, 0, 0);">n<HEAD>\n<TITLE>Page %d</TITLE>\n\n",</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
DOCTYPE, page);</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
+ else</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
+ fprintf(pageFile,"%s\n<HTML>\</span><span style="color: rgb(255, 0, 0);">n<HEAD>\n<TITLE> %s</TITLE>\n\n",</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
DOCTYPE, tmp->getCString());////file name</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
***********************</span><br style="color: rgb(255, 0, 0);">
<br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
I'm also concerned about you adding various <HTML> to the same .html page, my</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
limited HTML knowledge says you can only have one of those.</span></blockquote><div> <br>For the above: I would like to say that every page has different heading details as well as title. This should not be changed for pages. <br>
</div>
<div> </div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;"> <br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
Also it would be necessary that you update the pdftohtml.1 file (the man page)</span><br style="color: rgb(255, 0, 0);"><span style="color: rgb(255, 0, 0);">
adding the new option.</span></blockquote><div>pdftohtml.1 is updated.<br><br>Please find the latest patch for "pdftohtml -s <file.pdf> " and give feedback.<br><br></div><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<br style="color: rgb(255, 0, 0);">
<font color="#888888"><br>
Albert<br>
</font><div><div></div><div><br>
><br>
> With best regard<br>
> Leena C<br>
><br>
> On Wed, Jun 23, 2010 at 1:19 AM, Albert Astals Cid <<a href="mailto:aacid@kde.org" target="_blank">aacid@kde.org</a>> wrote:<br>
> > A Dimarts, 22 de juny de 2010, leena chourey va escriure:<br>
> > > Dear Albert,<br>
> > ><br>
> > > Thanks for giving detail comment to patch.<br>
> ><br>
> > > Please check updates given inline:<br>
> > Please do not forget to CC the poppler mailing list.<br>
> ><br>
> > > On Thu, Jun 17, 2010 at 4:14 AM, Albert Astals Cid <<a href="mailto:aacid@kde.org" target="_blank">aacid@kde.org</a>><br>
> ><br>
> > wrote:<br>
> > > > A Dimecres, 16 de juny de 2010, omkar va escriure:<br>
> > > > > Dear Albert,<br>
> > > > ><br>
> > > > > Please find the corrected patch for "accessibility of pdf document<br>
> > > > > " and give your feedback.<br>
> > > ><br>
> > > > Hi, some comments:<br>
> > > > * The comments like<br>
> > > > // One more parameter(int j) is added in the getCSStyle function by<br>
> ><br>
> > CDAC<br>
> ><br>
> > > > developer Team<br>
> > > ><br>
> > > > need to be removed, if each line had near it who coded it, the code<br>
> > > > will<br>
> > > ><br>
> > > > be<br>
> > > > twice as big and much more unreadable<br>
> > ><br>
> > > Done, deleted all unwanted comments<br>
> > ><br>
> > > > * The spacing of your patches could be better, that is<br>
> > > ><br>
> > > > GooString* HtmlFontAccu::getCSStyle(int i, GooString* content ,int<br>
> > > > j){ should be<br>
> > > > +GooString* HtmlFontAccu::getCSStyle(int i, GooString* content, int<br>
> > > > j){ but that's nothing huge, i can fix it<br>
> > ><br>
> > > Updated accordingly.<br>
> > ><br>
> > > > * You are leaking (i.e. not deleting) jStr in both<br>
> > > ><br>
> > > > HtmlFontAccu::getCSStyle<br>
> > > > and HtmlFontAccu::CSStyle<br>
> > ><br>
> > > Deleted jStr<br>
> > ><br>
> > > > * I see that the new HtmlPage::complexHtml and the old<br>
> > > ><br>
> > > > HtmlPage::dumpComplex<br>
> > > > are very simple, i if you reused the code instead of copying it<br>
> > > ><br>
> > > > * This introduces a behavioural change that is unaccetable, i<br>
> ><br>
> > understand<br>
> ><br>
> > > > you<br>
> > > > want pdftohtml to produce a different (in your opinion better)<br>
> > > > output, for that you'll have to introduce a new comandline option to<br>
> > > > pdftohtml (something<br>
> > > > like --singlehtml) or something like that<br>
> > ><br>
> > > For last 2 point we want some clarification.<br>
> > > As you said behavioural change is unacceptable and also suggested to<br>
> > > introduce a new command line option to generate single html. So if we<br>
> > > do<br>
> ><br>
> > as<br>
> ><br>
> > > following, will it be acceptable?<br>
> > ><br>
> > > - *Existing is:*<br>
> > > Command line option: pdftohtml -c <filename><br>
> > ><br>
> > > Function called:<br>
> > > dumpComplex<br>
> > ><br>
> > > ()<br>
> > > {<br>
> > ><br>
> > > Read from input file<br>
> > > Write into file to Generates pagewise html format<br>
> > ><br>
> > > }<br>
> > ><br>
> > ><br>
> > > - *Proposed changes:*<br>
> > > New Command line option : pdftohtml -s <filename> //Checked,<br>
> > > nothing is already defined for -s (pdftohtml -c<br>
> ><br>
> > <filename><br>
> ><br>
> > > will exists as it is)<br>
> > ><br>
> > > - Function called:<br>
> > > dumpSingle() //new function similar to<br>
> > ><br>
> > > dumpComplex {<br>
> > ><br>
> > > Read from input file<br>
> > > Write into file to append single html format<br>
> > ><br>
> > > }<br>
> > ><br>
> > > - A function to “Read from input file” can be defined and call it in<br>
> > ><br>
> > > both dumpComplex() and dumpSingle(), So that code duplication can be<br>
> > > removed (for second last point of your mail).<br>
> > ><br>
> > > - And with -s option (for --single Html) behavioural change will be<br>
> > > defined separately. (-c will not be affected)<br>
> ><br>
> > To be clear, pdftohtml -c should produce exactly the same output it did<br>
> > before<br>
> > your patch, pdftohtml -s you can output your version.<br>
> ><br>
> > So yes, i think i kind of agree with your proposal.<br>
> ><br>
> > Albert<br>
> ><br>
> > > For your opinion<br>
> > ><br>
> > > With Regards<br>
> > > Leena C & Onkar P<br>
> > > (for CDAC Accessibility Team)<br>
</div></div></blockquote></div>With best regards<br>Leena C<br>