[pulseaudio-discuss] PulseAudio prompts "I: module-alsa-sink.c: Underrun!".

Colin Guthrie gmane at colin.guthr.ie
Sun Nov 23 15:23:39 PST 2008

Dino wrote:
> Colin Guthrie wrote:
>> Dino wrote:
>>> I did recompile the latest PulseAudio, mplayer, alsa-plugin (without 
>>> alsa-lib, alsa-driver recompile), still not working.
>>> So I switch ALSA to OSS. Now it works...
>> When you say "latest" do you mean git master or 0.9.13? As I mentioned 
>> in my previous mail, 0.9.13 needs a lot of patches from git master to 
>> make it work reliably.
> I mean 0.9.13. but then I tried git-master, the problem still there, and 
> I got a new one.
> E: sink.c: Assertion 'PA_SINK_INPUT_IS_LINKED(st)' failed at 
> pulsecore/sink.c:1033, function pa_sink_check_suspend(). Aborting.

Oh yeah there is a problem in master at the moment (/me wished it had 
been fixed before Lennart went on holiday!)

This should work around it (not sure if it's the right fix or not tho).



Colin Guthrie

Day Job:
   Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
   Mandriva Linux Contributor [http://www.mandriva.com/]
   PulseAudio Hacker [http://www.pulseaudio.org/]
   Trac Hacker [http://trac.edgewall.org/]

More information about the pulseaudio-discuss mailing list