[Spice-devel] [PATCH 03/23] server/red_worker: add send_item

Alon Levy alevy at redhat.com
Mon Feb 28 07:46:32 PST 2011


On Sat, Feb 12, 2011 at 09:02:51PM +0100, Marc-André Lureau wrote:
> ack
> 
> On Fri, Feb 11, 2011 at 6:22 PM, Alon Levy <alevy at redhat.com> wrote:
> > +    int during_send;
> >
> 
> ^^ what is this? perhaps it should be in patch 04 instead? could
> "sending" be a better name than "during_send"?

maybe, I don't see one better then the other. It's meant to prevent
recursive calls, it is already in red_channel, at the end of the series
it is left only in red_channel.c, so I'll give an example using it:

red_channel_client_push
 during_send = TRUE
 red_channel_client_send-item
  channel->send_item==display_channel_send_item
   red_channel_client_push
   during_send == TRUE => returns immediately

I might have added it a bit too early.

> 
> -- 
> Marc-André Lureau


More information about the Spice-devel mailing list