[Spice-devel] [PATCH spice v3 0/6] Rewrite image compression

Pavel Grunt pgrunt at redhat.com
Wed Jan 20 05:15:20 PST 2016


Hi,

the intention of the series is to make the image compression code more readable
and also to do some clean up. There were two places where an algorithm for choosing
the compression type was implemented - in dcc.c and dcc-send.c. In order to avoid
the duplication, dcc_compress_image() is slightly modified and reused.
The patch 5/6 of the series tries to refactor the compression code
to make more clear when each of the compression methods should be used.

Thanks,

Pavel Grunt (6):
  build-sys: Update spice-common submodule
  dcc_compress_image: Handle NULL drawable
  dcc-send: Use dcc_compress_image to compress image
  dcc: make dcc_compress_image_*() private
  dcc: Rewrite dcc_image_compress
  dcc: Move COMPRESS_DEBUG to compression functions

 server/dcc-send.c |  44 +--------
 server/dcc.c      | 264 ++++++++++++++++++++++++++++++------------------------
 server/dcc.h      |  15 ----
 spice-common      |   2 +-
 4 files changed, 152 insertions(+), 173 deletions(-)

-- 
2.5.0



More information about the Spice-devel mailing list