[Spice-devel] [PATCH 04/15] inputs_init() -> inputs_channel_new()

Frediano Ziglio fziglio at redhat.com
Fri Jan 22 04:14:56 PST 2016


> 
> From: Jonathon Jongsma <jjongsma at redhat.com>
> 
> Rename function to be more consistent
> ---
>  server/inputs-channel.c | 2 +-
>  server/inputs-channel.h | 2 +-
>  server/reds.c           | 2 +-
>  3 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/server/inputs-channel.c b/server/inputs-channel.c
> index 50650b9..a5959c1 100644
> --- a/server/inputs-channel.c
> +++ b/server/inputs-channel.c
> @@ -605,7 +605,7 @@ static int
> inputs_channel_handle_migrate_data(RedChannelClient *rcc,
>      return TRUE;
>  }
>  
> -InputsChannel* inputs_init(void)
> +InputsChannel* inputs_channel_new(void)
>  {
>      ChannelCbs channel_cbs = { NULL, };
>      ClientCbs client_cbs = { NULL, };
> diff --git a/server/inputs-channel.h b/server/inputs-channel.h
> index ecd1dd7..d26ae43 100644
> --- a/server/inputs-channel.h
> +++ b/server/inputs-channel.h
> @@ -26,7 +26,7 @@
>  
>  typedef struct InputsChannel InputsChannel;
>  
> -InputsChannel* inputs_init(void);
> +InputsChannel* inputs_channel_new(void);
>  const VDAgentMouseState *inputs_channel_get_mouse_state(InputsChannel
>  *inputs);
>  void inputs_channel_on_keyboard_leds_change(InputsChannel *inputs, uint8_t
>  leds);
>  void inputs_channel_set_tablet_logical_size(InputsChannel *inputs, int
>  x_res, int y_res);
> diff --git a/server/reds.c b/server/reds.c
> index 2cc48f0..bf4c63d 100644
> --- a/server/reds.c
> +++ b/server/reds.c
> @@ -3414,7 +3414,7 @@ static int do_spice_init(RedsState *reds,
> SpiceCoreInterface *core_interface)
>  #endif
>  
>      reds->main_channel = main_channel_init();
> -    reds->inputs_channel = inputs_init();
> +    reds->inputs_channel = inputs_channel_new();
>  
>      reds->mouse_mode = SPICE_MOUSE_MODE_SERVER;
>  

Acked-by: Frediano Ziglio <fziglio at redhat.com>

Frediano


More information about the Spice-devel mailing list