[systemd-devel] slackware support

Lennart Poettering lennart at poettering.net
Sat May 15 14:49:07 PDT 2010

On Fri, 14.05.10 20:52, Malcolm Studd (mestudd at gmail.com) wrote:

> Attached is a patch for slackware support. If you want it some other
> way, let me know; I haven't used git before.

Thanks, commited.

> Slackware doesn't have gnome or vala, 

Oh god.

> and I'm having some issues with
> the vala programs in systemd. I installed the vala compiler, and the
> configure script says I have everything required, but compilation
> fails (log attached). Is there something I'm missing? I installed
> systemd by commenting out the vala programs in Makefile.am.

You need to update your vala. (or, alternatively just fix a typo in
/usr/share/vala/vapi/posix.vapi where there is one char uppercase that
should be lowercase in the qsort related annotations, iirc)


Lennart Poettering                        Red Hat, Inc.
lennart [at] poettering [dot] net
http://0pointer.net/lennart/           GnuPG 0x1A015CC4

More information about the systemd-devel mailing list