[systemd-devel] [PATCH] Don't require vala if gtk is disabled
Lucas De Marchi
lucas.demarchi at profusion.mobi
Tue Nov 16 14:50:23 PST 2010
On Tue, Nov 16, 2010 at 8:04 PM, Lennart Poettering
<lennart at poettering.net> wrote:
> On Tue, 16.11.10 11:47, Lucas De Marchi (lucas.demarchi at profusion.mobi) wrote:
> Vala is actually not required for building the tarball, since the
> tarball includes generated code. However, we do require people who build
> from git to have a recent Vala version around, so that the tarballs they
> can build from that are complete.
True, but if I explicitly disabled the gtk tools, I don't see the point
of requiring vala to build systemd, even if I'm working with the git version.
> It's a misconception that AM_PROG_VALAC would actually cause the build
> to fail. It does so only if you don't have the prebuilt stuff around.
Why do I need the prebuilt stuff if I'll not use it?
The problem with recent systemd commits is that they began to require
libnotify >= 0.7 and vala >= 0.11. For Archlinux it's a bit worse
because libnotify 0.7 depends on
gtk3. So it's also misleading to say that we depend on gtk2 when gtk
tools are enabled.
At least Archlinux does not plan to support gtk3 until gnome3 is
around, so if there is a simple yet effective way for disabling them
altogether I think it'd be great.
About the libnotify dependence, Archlinux was using version 0.4.5 and
I already told them that an updated was needed. However they couldn't
update to 0.7 because of the gtk3 dependency. As of now, 0.5.2 is
available in their repository. Is it possible to downgrade the
libnotify version required by systemd?
Lucas De Marchi
More information about the systemd-devel