[systemd-devel] [PATCH] buildsys: allow building without libnotify

Matthias Clasen matthias.clasen at gmail.com
Wed Nov 24 07:02:05 PST 2010

On Wed, Nov 24, 2010 at 9:56 AM, Kay Sievers <kay.sievers at vrfy.org> wrote:

>> Of course, distributions may still decide the other way, and introduce
>> a libnotify06 package...
> Sure, that's the default for Debian/Ubuntu/SUSE, to have rpm names for
> libs with the so version:
>  libnotify-devel-0.6.0-1.2.x86_64
>  libnotify1-0.6.0-1.2.x86_64
>  libnotify-tools-0.6.0-1.2.x86_64
> I guess the so version is now 2? But the problem remains that the
> devel package has conflicting files then. :)

Its 4 actually, for some reason.
As for the file conflicts: you could just do the one-time porting thing... :-).
Patches for most libnotify users should be in rawhide packages and
upstream  bugtrackers by now.

More information about the systemd-devel mailing list