[Bug 27204] Codegen erroneously uses enums' value-prefix as the name for the C++ enum

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Mar 19 20:14:16 CET 2010


http://bugs.freedesktop.org/show_bug.cgi?id=27204





--- Comment #1 from Will Thompson <will.thompson at collabora.co.uk>  2010-03-19 12:14:15 PST ---
The corresponding tp-glib codegen (which looks remarkably similar) does
something more like what I would have expected, separating the name from the
value prefix:

    def do_enum(self, enum):
        name = enum.getAttribute('singular') or enum.getAttribute('name')
        value_prefix = enum.getAttribute('singular') or \
                       enum.getAttribute('value-prefix') or \
                       enum.getAttribute('name')
        name_plural = enum.getAttribute('plural') or \
                      enum.getAttribute('name') + 's'


-- 
Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the telepathy-bugs mailing list