[Bug 46345] tp-salut does not build on windows/mingw32

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Feb 22 03:20:50 CET 2012


--- Comment #4 from Siraj Razick <siraj.razick at collabora.co.uk> 2012-02-21 18:20:50 PST ---
(In reply to comment #3)
> (In reply to comment #2)
> > Typically --with args are used in configure for when you want to do
> > --with-some-dependency-lib --without-some-dependency-lib . 
> > 
> > Thus, I'd make this --zeroconf-backend=dummy/avahi for now.
> The documented convention in Autoconf is that --with is for optional packages,
> whereas --enable is for including or omitting parts of this package, and the
> docs specifically say "--enable-FEATURE should never make a feature behave
> differently or cause one feature to replace another".
> As far as I can see, the Autoconf docs would want you to use --with-avahi and
> --with-libdns-sd, have the default be --with-avahi, make --with-avahi
> --with-libdns-sd be an error (or use Avahi because it's better?), and make
> --without-avahi use the dummy backend? Or something.
> I think --with-backend=[avahi|libdns_sd|no] would be fine, tbh. If you make the
> "dummy" case be "no" instead of "dummy", then people wanting the dummy backend
> can use --without-backend (which is exactly equivalent to --with-backend=no).

the branch is now updated with the suggested changes.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA Contact for the bug.

More information about the telepathy-bugs mailing list