[uim-commit] r2756 - branches/r5rs/sigscheme

yamaken at freedesktop.org yamaken at freedesktop.org
Tue Jan 3 03:17:49 PST 2006


Author: yamaken
Date: 2006-01-03 03:17:40 -0800 (Tue, 03 Jan 2006)
New Revision: 2756

Modified:
   branches/r5rs/sigscheme/sigscheme.h
Log:
* sigscheme/sigscheme.h
  - (SCM_REINTERPRET_CAST): Removed. Use ordinary cast with uintptr_t
    instead


Modified: branches/r5rs/sigscheme/sigscheme.h
===================================================================
--- branches/r5rs/sigscheme/sigscheme.h	2006-01-03 11:15:31 UTC (rev 2755)
+++ branches/r5rs/sigscheme/sigscheme.h	2006-01-03 11:17:40 UTC (rev 2756)
@@ -66,13 +66,6 @@
 #define SCM_NORETURN
 #endif /* __GNUC__ */
 
-/*
- * Re-interprets a storage as-is, similarly to reinterpret_cast<type>(obj) of
- * C++. Don't change the semantics. This cast requires that obj is a pointable
- * storage.
- */
-#define SCM_REINTERPRET_CAST(type, obj) (*(type *)&(obj))
-
 /* RFC: better names for the debug printing */
 #if SCM_DEBUG
 #define SCM_CDBG(args) (scm_categorized_debug args)



More information about the uim-commit mailing list