[Uim] Replacing property handling codes with property.scm
yamaken at bp.iij4u.or.jp
Mon Nov 1 20:19:52 EET 2004
At Mon, 1 Nov 2004 14:44:13 +0900,
tkng at xem.jp wrote:
> On Sat, 30 Oct 2004 05:44:54 +0900
> YamaKen <yamaken at bp.iij4u.or.jp> wrote:
> > > > > > ui-unit is easier than manipulator for me.
> > > > >
> > > > > Okay. It's the most preferable candidate for now. Propose
> > > > > better name if you have found.
> > > >
> > > > I would like to use the word 'widget' instead of 'ui-unit'. How
> > > > do you feel it?
> > >
> > > ui-unit is better for me. widget will be confusing.
> > What confuses you?
> As you said, we are familiar with 'window gadget' rather than 'A small
> mechanical device or control; a gadget.'. I think this will be a reason
> of confusion. To be honest, I couldn't imagne except window gadget in
> GUI toolkit with the word 'widget'. (Though maybe this is only my bad
It will not cause problems as I said in previous message.
At Fri, 29 Oct 2004 03:51:23 +0900,
yamaken at bp.iij4u.or.jp wrote:
> Although we are familiar with 'window gadget' rather than above
> definition, the difference will not cause problems.
My intention about the word 'widget' is an unit of user
interface entity. The meaning will not be altered even if the
word is recognized as 'window gadget' as in GUI toolkits.
i.e. A widget of an input method represents a widget of a GUI
toolkit. See action.scm I had recently committed.
YamaKen yamaken at bp.iij4u.or.jp
More information about the uim