[Uim] Suggestion: im-label-name
tkng at xem.jp
Sat Jan 29 01:05:16 EET 2005
On Mon, 17 Jan 2005 21:25:15 +0900
YamaKen <yamaken at bp.iij4u.or.jp> wrote:
> At Sat, 15 Jan 2005 04:34:38 +0900,
> tkng at xem.jp wrote:
> > On Fri, 14 Jan 2005 05:21:52 +0900
> > YamaKen <yamaken at bp.iij4u.or.jp> wrote:
> > > I welcome better name. But human-readable-name is not. It makes
> > > confusion since im-name is also human readable (e.g. 'anthy).
> > IMHO the existence of uim_get_im_human_readable_name doesn't mean
> > im-name is not human readable.
> Existence of im-name means that the word "human readable"
> provides no information about its role since im-name may be an
> human readable name.
What I couldn't understand is that 'Existence of im-name means that the
word "human readable" provides no information about its role'. Why human
readable provides no infomation if im-name may be an human readable
name? I want know that point.
If I saw both of uim_get_im_human_readable_name uim_get_im_name, I'll
use former to display input method name, because the former ensures
returned value is human readable.
> If we can revise the uim API, im-name should also be renamed to
> more specific one such as im-idname to indicate its role. But
> now is not the time, so we have to indicate the difference of
> the two functions by naming latter one obviously.
Providing new api uim_get_im_id and marking uim_get_im_name as
deprecated seems no problem (if you want).
> > > The name im-label-name is also. So there is no reason
> > > distinguishing them, I think. I'll search for another solution
> > > if you are still feeling odd.
> > As described above, I can allow uim_get_im_label or
> > uim_get_im_name_label. But IMHO human_readable_name is better. How
> > about uim_get_im_name_for_display?
> Feeling not enough. I suggest im-explanatory-name. Would you
> accept it?
IMHO explanatory is not appropriate... Because human readable doesn't
means explanatory. For example, 'Anthy' is not explanatory. Newbie would
not be able to guess that 'Anthy' is a Japanese conversion engine.
> By the way, do you mean that C API
> (uim_get_im_explanatory_name()) is also required?
As a conclusion, following list is my candidate. If I implement, I'll
use uim_get_im_human_readable_name. But I don't have enough energy to
continue this discussion, you should use your best naming. Implementor
sould have a right to determine the function name.
- Best: uim_get_im_human_readable_name
- Second best: uim_get_im_name_for_display
- Third best: uim_get_im_label or uim_get_im_name_label
tkng at xem.jp
More information about the uim