[PATCH 2/2] input: define two variable conventions for input types
ppaalanen at gmail.com
Mon Dec 12 22:50:40 PST 2011
On Mon, 12 Dec 2011 18:55:44 +0200
Tiago Vignatti <vignatti at freedesktop.org> wrote:
> From: Tiago Vignatti <tiago.vignatti at intel.com>
> wl_input_device → winput_dev
> wlsc_input_device → input_dev
> i.e. respectively type definition and variable name.
> Previously we had "device", "dev", "eid", "input_device", "wd", among
> others to possibly describe the same type. My intention is that we
> respect this new convention when developing from now on, so we
> benefit from a nicer readability, easier ways to find code and
> overall better organization.
Oh yes, I like that. If I ever have free time, I'd like to do something
similar to wl_surface, wlsc_surface, shell_surface types.
> For now we're gonna end up with a few repetitive snips like
> input_dev->winput_dev, but that will have a better meaning when we
> introduce group class for input devices on the protocol.
> Signed-off-by: Tiago Vignatti <tiago.vignatti at intel.com>
Quickly compile-tested this patch set, and ran a couple demo clients,
seems to be ok. Didn't read through the patches, though.
More information about the wayland-devel