[RFC 2/2] server: add WL_GUARD macros

Daniel Stone daniel at fooishbar.org
Fri Mar 2 08:55:34 PST 2012


On 2 March 2012 12:13, Pekka Paalanen <ppaalanen at gmail.com> wrote:
> Does this make the code easier to read or not?
> I cannot judge it, since I wrote the macros.

To be honest, I don't think so.  I don't think there's any benefit to
grepability and it does kinda obscure what it's doing somewhat.  The
guard objects themselves don't look like a bad idea though.


More information about the wayland-devel mailing list