[PATCH libinput] Name-space the scroll event types

Peter Hutterer peter.hutterer at who-t.net
Sun Apr 27 22:38:46 PDT 2014


To provide a generic naming system of type_direction. That will become more
important once we add new axes as part of the ongoing work to support graphics
tablets.

Signed-off-by: Peter Hutterer <peter.hutterer at who-t.net>
---
 src/libinput.h | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

diff --git a/src/libinput.h b/src/libinput.h
index d771e21..df9a382 100644
--- a/src/libinput.h
+++ b/src/libinput.h
@@ -147,8 +147,14 @@ enum libinput_pointer_button_state {
  * Axes on a device that are not x or y coordinates.
  */
 enum libinput_pointer_axis {
-	LIBINPUT_POINTER_AXIS_VERTICAL_SCROLL = 0,
-	LIBINPUT_POINTER_AXIS_HORIZONTAL_SCROLL = 1
+	LIBINPUT_POINTER_AXIS_SCROLL_VERTICAL = 0,
+	LIBINPUT_POINTER_AXIS_SCROLL_HORIZONTAL = 1,
+
+
+	/** @deprecated Use @ref LIBINPUT_POINTER_AXIS_SCROLL_VERTICAL instead */
+	LIBINPUT_POINTER_AXIS_VERTICAL_SCROLL = LIBINPUT_POINTER_AXIS_SCROLL_VERTICAL,
+	/** @deprecated Use @ref LIBINPUT_POINTER_AXIS_SCROLL_HORIZONTAL instead */
+	LIBINPUT_POINTER_AXIS_HORIZONTAL_SCROLL = LIBINPUT_POINTER_AXIS_SCROLL_HORIZONTAL
 };
 
 /**
-- 
1.9.0



More information about the wayland-devel mailing list