[PATCH weston 3/5] client: Add DnD cursors to the managed cursors list

Carlos Garnacho carlosg at gnome.org
Fri Jan 15 15:52:48 PST 2016


Hey Bryce :),

On Sat, Jan 16, 2016 at 12:13 AM, Bryce Harrington
<bryce at osg.samsung.com> wrote:
> On Fri, Jan 15, 2016 at 09:14:25PM +0100, Carlos Garnacho wrote:
>> That way we'll be able to set the corresponding pointer surface to
>> a current DnD operation.
>>
>> Signed-off-by: Carlos Garnacho <carlosg at gnome.org>
>> Reviewed-by: Jonas Ã…dahl <jadahl at gmail.com>
>> ---
>>  clients/window.c | 16 ++++++++++++++++
>>  clients/window.h |  3 +++
>>  2 files changed, 19 insertions(+)
>>
>> diff --git a/clients/window.c b/clients/window.c
>> index 3e5885e..e9e8de9 100644
>> --- a/clients/window.c
>> +++ b/clients/window.c
>> @@ -1261,6 +1261,19 @@ static const char *watches[] = {
>>       "0426c94ea35c87780ff01dc239897213"
>>  };
>>
>> +static const char *move_draggings[] = {
>> +     "dnd-move"
>> +};
>
> Any reason this must be 'draggings' rather than 'drags'?

Maybe not a big one, "drags" sounded too much like ongoing
action/state to me. The naming scheme for these arrays is somewhat
unfortunate, it feels more natural to invert the name here, but
"drag_moves" or "dnd_moves" sounds equally awkward. Suffixing
"_cursors" in these would make for better names IMO, like
dnd_move_cursors.

Cheers,
  Carlos


More information about the wayland-devel mailing list