<br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="HOEnZb"><div class="h5">
> interface = seat->pointer->grab->interface;<br>
> @@ -2456,13 +2456,14 @@ weston_text_cursor_position_notify(struct weston_surface *surface,<br>
> if (output->zoom.active &&<br>
> pixman_region32_contains_point(&output->region,<br>
> cur_pos_x, cur_pos_y, NULL))<br>
> - weston_output_update_zoom(output, cur_pos_x * 256, cur_pos_y * 256);<br>
> + weston_output_update_zoom(output, cur_pos_x * 256, cur_pos_y * 256, 1);<br>
> }<br>
><br>
> WL_EXPORT void<br>
> -weston_output_update_zoom(struct weston_output *output, wl_fixed_t fx, wl_fixed_t fy)<br>
> +weston_output_update_zoom(struct weston_output *output, wl_fixed_t fx, wl_fixed_t fy, int text_cursor)<br>
<br>
</div></div>Boolean arguments makes the code hard to read, use an enum instead.<br>
Compare<br>
<div class="im"><br>
weston_output_update_zoom(output, cur_pos_x * 256, cur_pos_y * 256, 1);<br>
<br>
</div>to<br>
<br>
weston_output_update_zoom(output, cur_pos_x * 256, cur_pos_y * 256, ZOOM_TEXT_CURSOR);<br>
<br>
Kristian<br><br></blockquote><div> </div><div>Yes, I did consider this but never got around to implementing it.<br><br><br>Scott<br></div></div><br>