[Xcb] status of xcb_util
jkolb at brandeis.edu
Mon Nov 13 20:41:22 PST 2006
Josh Triplett wrote:
> Thomas Hunger wrote:
>> The util package is nice and I use it lots. I think it should be
>> integral part of xcb since it provides a lot of functions which
>> everyone needs (e.g. the icccm helpers).
>> I would also like to change the naming in util a little: Now there
>> is "AllocSizeHints" which would convert to "alloc_size_hints". I
>> would like to add the additional namespace "xcb_util_".
>> That would allow me to see where the function originates, which helps
>> a lot in debugging and reading code. It could also prevent name
>> clashes (Althout they seem very unlikely for these functions).
> Rather than using an xcb_util_ prefix, and updating and releasing it as one
> package, I think we need to split out individual libraries from xcb-util and
> version and release them separately. For example, we really need to put out a
> release of libxcb-renderutil, whereas libxcb-wm may not necessarily become
> suitable for release anytime soon.
> - Josh Triplett
Would it be a good idea to make them extension specific? It might be
nice so we have support (or a common naming scheme at least) or
xcb_$ext_util/aux or something like that. There are a few extensions
that would really benefit from such utility libraries.
More information about the Xcb