[Xcb] final ABI change for RC2; soname bump

Jeremy Kolb jkolb at brandeis.edu
Fri Oct 6 15:32:34 PDT 2006


Jamey Sharp wrote:
> In our announcement of XCB 1.0 RC1, we noted:
> 
> 	We would greatly appreciate API review in this final release
> 	candidate period. We've had some limited feedback that our
> 	attempts to impose static type safety on XIDs in C pose more a
> 	hindrance than a help, so we would appreciate discussion over
> 	whether this constitutes a "serious issue with the API". Some
> 	question also remains of whether xcb_poll_for_event should have
> 	the out-parameter 'error', now that XCB has a more uniform
> 	mechanism for reporting connection errors.
> 
> Since we've received feedback agreeing with our proposed changes, and no
> support for the existing API, we plan to make both changes and bump the
> soname to 1.0.0 in preparation for the release of XCB 1.0 final. We'll
> release these changes as XCB 1.0 RC2 soon, probably today.
> 
> Once more, the two changes are these:
> 
> Where XCB currently declares a structure containing a single uint32_t
> for each XID type, it will instead typedef uint32_t to the XID type
> name.
> 
> Where XCB currently provides this function:
> 
> xcb_generic_event_t *xcb_poll_for_event(xcb_connection_t *c, int *error);
> 
> It will instead provide the simpler interface:
> 
> xcb_generic_event_t *xcb_poll_for_event(xcb_connection_t *c);
> 
> On I/O or other errors, xcb_poll_for_event will return null and shut
> down the xcb_connection_t. It will no longer terminate the application
> under any circumstances.
> 
> --Jamey
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Xcb mailing list
> Xcb at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/xcb

Review would be good, especially wrt naming consistency.  For instance
I've seen some of this:
major_version/server_major_version/server_$ext_version in the query
version functions.  Field names especially need a good consistency check.

Jeremy


More information about the Xcb mailing list