<br>Hi :),<br><br>Nice hearing from you. Please give me the link to the WindowsWM extension and the mail by Alan being referred to here and I'll get back.<br><br>Regards,<br>Jeetu<br><br><br><div class="gmail_quote">On Sun, Oct 4, 2009 at 11:16 AM, Vincent Torri <span dir="ltr"><<a href="mailto:vtorri@univ-evry.fr">vtorri@univ-evry.fr</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>
Hey,<br>
<br>
Just a note: i've just seen in Alan's mail about xorg 7.5 that there is a WindowsWM extension, for better coordination between an X11 server and the Windows desktop shell<br>
<br>
Would it be usefull to have that extension for the windows port of XCB ?<br>
<br>
Vincent<div><div></div><div class="h5"><br>
<br>
On Wed, 20 May 2009, Jeetu Golani wrote:<br>
<br>
</div></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div><div></div><div class="h5">
Hi Barton,<br>
<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
I don't have much to contribute, I'm afraid. :-) Just big<br>
thank-yous to Jeetu and Julien; I'm really pleased to see<br>
this move forward.<br>
</blockquote>
<br>
Appreciate the opportunity and glad I could help. I would like to thank<br>
Vincent, Peter and Julien for their help and of course all the rest of the<br>
devels who have put together quite a cool library :)<br>
<br>
Hopefully will put together the changes recommended by everyone soon.<br>
<br>
Bye for now<br>
<br>
<br>
<br>
On Wed, May 20, 2009 at 10:33 AM, Barton C Massey <<a href="mailto:bart@cs.pdx.edu" target="_blank">bart@cs.pdx.edu</a>> wrote:<br>
<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
I don't have much to contribute, I'm afraid. :-) Just big<br>
thank-yous to Jeetu and Julien; I'm really pleased to see<br>
this move forward.<br>
<br>
Bart<br>
<br>
In message <<a href="mailto:20090518084622.GA30591@abydos.adm.naquadah.org" target="_blank">20090518084622.GA30591@abydos.adm.naquadah.org</a>> you wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br>
--===============0102780725==<br>
Content-Type: multipart/signed; micalg=pgp-sha1;<br>
protocol="application/pgp-signature"; boundary="3MwIy2ne0vdjdPXF"<br>
Content-Disposition: inline<br>
<br>
<br>
--3MwIy2ne0vdjdPXF<br>
Content-Type: text/plain; charset=utf-8<br>
Content-Disposition: inline<br>
Content-Transfer-Encoding: quoted-printable<br>
<br>
HI,<br>
<br>
At 1242038193 time_t, Jeetu Golani wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
I've updated my branch at github to reflect changes in code as<br>
</blockquote></blockquote>
suggested =<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
by<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Julien and also rectify the goof ups I made with my initial submission.<br>
=20<br>
Julien, I would appreciate if you could verify if all is well now.<br>
</blockquote>
<br>
Yeah, that's much better. :-)<br>
<br>
I'll quote some of your work here and just review it. I'm not qualified<br>
in Windows coding so I won't judge if the work is good, bad or even<br>
functionnal.<br>
<br>
--- /dev/null<br>
+++ b/src/windefs.h<br>
[...]<br>
+#define WINVER 0x0501 /* required for getaddrinfo/freeaddrinfo defined<br>
</blockquote>
onl=<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
y for WinXP and above */<br>
<br>
Hum, are you sure you always want to define it?<br>
If not, maybe adding #ifndef WINVER / #endif surrounding this #define<br>
might be a good idea.<br>
<br>
<br>
--- a/src/xcb_in.c<br>
+++ b/src/xcb_in.c<br>
+static int read_block(const int fd, void *buf, const size_t len)<br>
and<br>
+int _xcb_in_read(xcb_connection_t *c)<br>
<br>
You are redefining the whole function. IMHO, this is not so good,<br>
because you are duplicating a lot of code. And is some day we need to<br>
fix code in one of that function, we may forget to fix it in the WIN32<br>
version.<br>
<br>
<br>
--- a/src/xcb.h<br>
+++ b/src/xcb.h<br>
+int initWSA(void);<br>
<br>
This is not right. If I'm understanding correctly, this is required to<br>
initialize some stuff. The function name is not respecting the naming<br>
scheme of xcb functions and the name is too generic.<br>
<br>
I suggest that:<br>
1. You drop the function and documente that loading winsock via<br>
WSAStartup() is mandatory before using XCB;<br>
2. or you add a static flag in xcb_open() that check that winsock has<br>
</blockquote>
been<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
initialized before running;<br>
3. or you initialize winsock in xcb_open() unconditionnally. I don't know<br>
if you can initialize winsock multiple times. If not, the solution<br>
above can be better. But again, maybe another lib can initiliaze<br>
winsock in its corner, so maybe if it can be initialized only once,<br>
solution 1 will be better.<br>
<br>
The rest seems fine to me.<br>
<br>
Cheers,<br>
--=20<br>
Julien Danjou<br>
// =E1=90=B0 <<a href="mailto:julien@danjou.info" target="_blank">julien@danjou.info</a>> <a href="http://julien.danjou.info" target="_blank">http://julien.danjou.info</a><br>
// 9A0D 5FD9 EB42 22F6 8974 C95C A462 B51E C2FE E5CD<br>
// When I get sad, I stop being sad and be awesome instead. True story.<br>
<br>
--3MwIy2ne0vdjdPXF<br>
Content-Type: application/pgp-signature; name="signature.asc"<br>
Content-Description: Digital signature<br>
Content-Disposition: inline<br>
<br>
-----BEGIN PGP SIGNATURE-----<br>
Version: GnuPG v1.4.9 (GNU/Linux)<br>
<br>
iEYEARECAAYFAkoRIF4ACgkQpGK1HsL+5c0fxACfZiIGTDyDnbPYUt7I02Szg5xv<br>
tJsAoNFkKUc1OjxugdpAG9U/sUifmgs6<br>
=HMAC<br>
-----END PGP SIGNATURE-----<br>
<br>
--3MwIy2ne0vdjdPXF--<br>
<br>
--===============0102780725==<br>
Content-Type: text/plain; charset="us-ascii"<br>
MIME-Version: 1.0<br>
Content-Transfer-Encoding: 7bit<br>
Content-Disposition: inline<br>
<br>
_______________________________________________<br>
Xcb mailing list<br>
<a href="mailto:Xcb@lists.freedesktop.org" target="_blank">Xcb@lists.freedesktop.org</a><br>
</blockquote>
<a href="http://lists.freedesktop.org/mailman/listinfo/xcb" target="_blank">http://lists.freedesktop.org/mailman/listinfo/xcb</a><br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
--===============0102780725==--<br>
</blockquote>
<br>
</blockquote>
<br></div></div>
-- <br>
Ce message a été vérifié par MailScanner<br>
pour des virus ou des polluriels et rien de<br>
suspect n'a été trouvé.<br>
Message délivré par le serveur de messagerie de l'Université d'Evry.<br>
<br>
</blockquote>
</blockquote></div><br>