Carsten Haitzler (The Rasterman)
raster at rasterman.com
Wed Feb 8 04:47:40 EET 2006
On Fri, 3 Feb 2006 07:19:31 -0700 "Aaron J. Seigo" <aseigo at kde.org> babbled:
> On Friday 03 February 2006 03:32, Carsten Haitzler wrote:
> > OK - for now i've dropped the menu stuff. i've attached a much mroe
> > detailed description of spec additions in the new_systray.txt. please read
> > it over and throw in suggestions on improvements. we should still discuss
> > the way of delivering icons i believe as there is no consensus yet. i
> > personally stand on the side of "stick clear of requiring extra extansions
> > to define the icons". (so re-use existing properties).
> one of the nice things is we get multiple icons sizes for the tray along the
> way. we may wish to recommend 16, 22 and 32px icons be provided for all
> systray entries as that will encourage developers to provide enough variety
> that the icons won't look like crap due to being scaled.
sure. though it's a trecommendation. in reality i see at most 2 sizes happening
and in future likely only 1 and peole will just live with a scaled down image
(the larger one just needs to refrain from too much detail) :) i've added the
note to an updated draf (attached).
> instead of using _NET_WM_ICON_NAME for the tooltip/popup text, could we
> perhaps use _NET_WM_VISIBLE_NAME instead for clarity's sake? i think having
> "SYSTEM_TRAY_ICON_NAME" being a name of an icon and "ICON_NAME" being text
> shown for the icon to be more than a little confusing, and were i reading it
> for the first time as an outsider i'd think "boy, they sure have trouble
> naming things clearly." ;)
i'm pretty agnostic here - but visible name is fine by me :)
> as for _NET_WM_NAME, i'm not sure if its enough for accessibility needs the
> way it's written: "This property should be used to identify the application
> name that owns this tray icon so it is easy to know where it came from." this
> may be interesting for systray implementations to use to connect the tray
> item with, say, taskbar entries .... but we probably want something more than
> "amarok", "kmail", "klaptopdaemon", etc... for screenreaders. if this is
> combined with the WM_ICON_NAME atom we'd get things like: "klaptopdaemon: 25%
> charged". we want something more like: "laptop battery monitor: 25% charged".
> while we could use NET_WM_NAME for this, we then lose the nice app<->tray
> entry mapping that would be useful elsewhere.
well i wasn't aiming at a specific name. i was aiming to stop bad examples like:
"idle with no connections"
what is that? maybe:
"not connected to instant messenger service. currently idle"
for an instant messenger systray icon. at least you know what it is "oh thats
my instant messenger app" - but if it doesnt even hint at what it may be -
that's bad. WM_CLASS can be used to identify the application explicitly i
think. anyway i've atttached an updated draft. comments of course are very much
> i'm on the fence as to whether we should use yet another atom here or rejig
> the definition of one of the ones already used in your draft spec here. but
> then, it's only 07:20 here so i don't expect non-fuzzy thinking yet ;)
> Aaron J. Seigo
> GPG Fingerprint: 8B8B 2209 0C6F 7C47 B1EA EE75 D6B7 2EB1 A7F1 DB43
> Full time KDE developer sponsored by Trolltech (http://www.trolltech.com)
------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler) raster at rasterman.com
Tokyo, Japan (東京 日本)
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
More information about the xdg