Direction arrows.

James Richard Tyrer tyrerj at
Mon Jun 25 14:39:04 PDT 2007

Diego Iastrubni wrote:
> ביום שני, 25 ביוני 2007, נכתב על ידי James Richard Tyrer:
>> I am aware of this issue and these two KDE3 icons: "previous" & "next"
>> shouldn't be interchanged for RTL language/locales.  Since these are not
>> the icons for a KDE Standard Action, this is an issue with individual
>> applications.  And yes, this should be in the HIG.
> Richard,
> If you talk about the icons on those buttons (in LTR, next points to the right 
> and in RTL ro the left), you missed my point. I am talking about the order of 
> those buttons.

OK, I think that I understand now.

Rather than have standard actions: "FindNext" and "FindPrevious" we 
should call them: "FindRight" and "FindLeft".  The icons should _always_ 
point Right and Left (respectively) and should not change for RTL. 
However, the function, menu string and tooltip should change.

That is for LTR, FindRight should have the function FindNext, but for 
RTL FindRight should have the function FindPrevious.

Which means that this code is not needed:

     if ( QApplication::isRightToLeft() ) {
       if ( id == Prior )
         iconName = "find-next";

       if ( id == Next )
         iconName = "find-previous";

but a considerable rewrite of kstandardaction.cpp and the header files 
is needed.

And this should be the same for all right/left text related standard 
actions.  GoBack & GoForward should be replaced by GoLeft & GoRight -- 
this code is also wrong:

       case Back:
         sLabel = i18nc( "go back", "&Back");
         if ( QApplication::isRightToLeft() )
           iconName = "go-next";

       case Forward:
         sLabel = i18nc( "go forward", "&Forward" );
         if ( QApplication::isRightToLeft() )
           iconName = "go-previous";

because it changes the icon and it should change the string -- and the 
missing ViewPrevious & ViewNext should be called ViewLeft & ViewRight.


More information about the xdg mailing list