Proposed draft for the thumbnail D-Bus specification
kevin.krammer at gmx.at
Fri Oct 17 08:09:14 PDT 2008
On Friday 17 October 2008, Philip Van Hoof wrote:
> The specification and the prototype have been adapted to this
>  https://stage.maemo.org/svn/maemo/projects/haf/trunk/hildon-thumbnail/
>  http://live.gnome.org/ThumbnailerSpec
Just a note:
The description of mime_hints should probably be phrased in D-Bus terms rather
than C terms:
"The optional mime_hints is either empty or of the same size as the uris."
"The optional mime_hints is either NULL or of the same size as the uris."
I wonder whether it would be cleaner to have an "overload", i.e. one Create
method without MIME hints and one CreateWithHints (or better name) with a(ss)
as input (array of (URI, MIME) pairs)
Kevin Krammer, KDE developer, xdg-utils developer
KDE user support, developer mentoring
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : http://lists.freedesktop.org/archives/xdg/attachments/20081017/a05004f2/attachment.pgp
More information about the xdg