Proposed draft for the thumbnail D-Bus specification
Philip Van Hoof
spam at pvanhoof.be
Thu Sep 4 01:59:55 PDT 2008
On Wed, 2008-09-03 at 13:38 -0400, Havoc Pennington wrote:
> dbus interface name should be Thumbnailer instead of thumbnailer to
> follow the naming conventions recommended in the dbus spec,
This has been fixed in both the specification and the prototype
> <arg type="u" name="handle" direction="out" />
> integer handles are almost always wrong in dbus; using an object path
> is probably more correct. A good pattern is to use a mktemp-style
> random string in the object path, to avoid ever having 'recycling'
> problems, even if a process restarts.
> The returned object from Queue can have an interface like ThumbnailJob
> and have a method Unqueue, for example.
It's not necessary to create a new object on the bus for this, in my
opinion. The handle is just for the unqueue, with an object on the bus
the application developer would have to track proxies to it to use the
unqueue operation. That sounds overkill to me. The Queue also has a
handle_to_unqueue, what should I pass here? The mktemp-style random
string? Right now both `handle_to_unqueue` and the `Unqueue` operation
share the same kind of things that get passed (a simple handle).
Not sure about this ...
> <interface name="org.freedesktop.thumbnailer.manager">
This is now org.freedesktop.Thumbnailer.Manager in both the spec and the
I modeled this like for example:
> is thumbnailer a namespace or an interface? Should probably be
Philip Van Hoof, freelance software developer
home: me at pvanhoof dot be
gnome: pvanhoof at gnome dot org
More information about the xdg