KNotificationItem specification - first draft
Jon A. Cruz
jon at joncruz.org
Mon Sep 7 10:24:44 PDT 2009
On Sep 7, 2009, at 2:36 AM, Aurélien Gâteau wrote:
> A name like KSystemTrayItem would avoid such confusions. I know it is
> probably not very appropriate because it describe a visualization
> than the content, but I feel it would still be better than
> KNotificationItem (Think about a new developer faced with choosing
> between the KNotification and KNotificationItem classes...)
Even in Microsoft Windows, it has never been called "system tray".
They had been careful from the beginning to call it the "notification
area" in APIs, user documentation, etc. Early on some people outside
of MS noticed "systray.exe" and so gave it a nickname.
So for developers who look into this at all, even Windows developers,
should be able to cope with the industry standard term.
More information about the xdg