makedepend: Changes to 'master'

GitLab Mirror gitlab-mirror at kemper.freedesktop.org
Tue Jan 3 19:11:47 UTC 2023


 configure.ac |    6 
 cppsetup.c   |   95 ++--
 def.h        |  198 ++++-----
 ifparser.c   |  627 +++++++++++++++-------------
 ifparser.h   |   21 
 imakemdep.h  |  427 +++++++++----------
 include.c    |  513 ++++++++++++-----------
 main.c       | 1278 +++++++++++++++++++++++++++++------------------------------
 parse.c      | 1123 ++++++++++++++++++++++++++-------------------------
 pr.c         |  197 ++++-----
 10 files changed, 2270 insertions(+), 2215 deletions(-)

New commits:
commit 14b042d2061409540c6f645271bf562d15cc14cb
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Wed Dec 7 15:54:43 2022 -0800

    Make more things static that aren't needed in more than one file
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit c46d912071dd8fad6c1ed532cbef26db34a639e9
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Wed Dec 7 11:17:32 2022 -0800

    Call strrchr() instead of hand coding a custom version
    
    Also correct comments on hand-coded custom strcmp() replacements
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 72a6cb64b0aded790e44d97e71434a4eddb91f15
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Wed Dec 7 10:11:04 2022 -0800

    Cache filename after realpath() processing
    
    Avoid having to make an additional system call for every time
    we compare full path names.
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit ffe60c0f58ae4b385ad733fad4455efaebdd1342
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 18:45:03 2022 -0800

    Make malloc error checking/reporting more consistent
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 37371f1cdcf351e29bf542e6b2fc269b29a4fba2
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 18:24:08 2022 -0800

    cppsetup: use C99 struct initialization
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit ce3d4de40fa89b2b209ab19acd763eec83bc70f1
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 18:17:12 2022 -0800

    Stop casting _parse_data pointers through (char *) and back
    
    Eliminates clang warnings:
    cppsetup.c:41:30: warning: cast from 'char *' to 'struct _parse_data *'
      increases required alignment from 1 to 8 [-Wcast-align]
        struct _parse_data *pd = (struct _parse_data *) ip->data;
                                 ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    cppsetup.c:69:30: warning: cast from 'char *' to 'struct _parse_data *'
      increases required alignment from 1 to 8 [-Wcast-align]
        struct _parse_data *pd = (struct _parse_data *) ip->data;
                                 ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 84f5fee3c769fc907c561110f4828416f921e81a
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 18:12:15 2022 -0800

    Handle some implicit conversion warnings from clang
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 40bcc8c3303a858c786f1d6d04ae5bbdec6b04ff
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 17:42:04 2022 -0800

    Use reallocarray() on systems that provide it
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 47f2e64d865568d4f00cb97e42ad5cfc47e9c161
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 17:27:04 2022 -0800

    quoteColons: Remove redundant initialization of tmp
    
    As warned by cppcheck:
    
    pr.c:83:9: style: Redundant initialization for 'tmp'. The initialized
      value is overwritten before it is read. [redundantInitialization]
        tmp = input;
            ^
    pr.c:74:21: note: tmp is initialized
        const char *tmp = input;
                        ^
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit d212d91dad2fdc3f30b79d90fca763659ac23307
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 17:24:15 2022 -0800

    find_includes: rename variables to avoid shadowing global
    
    Clears gcc warning:
    
    parse.c: In function ‘find_includes’:
    parse.c:620:29: warning: declaration of ‘inclistp’ shadows a global declaration [-Wshadow]
                 struct inclist *inclistp = inclistnext;
                                 ^~~~~~~~
    In file included from parse.c:27:0:
    def.h:171:26: note: shadowed declaration is here
     extern struct inclist   *inclistp;
                              ^~~~~~~~
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 0da7cf06cea7837f78ee53c310453a32356227b8
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 17:20:49 2022 -0800

    Store predefined -D values in const char fields
    
    Clears up 28 -Wdiscarded-qualifiers warnings from gcc
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 2bb1bd63e2e766ce281a61cadbffad7a12d5fd18
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 17:06:49 2022 -0800

    Variable scope reduction as suggested by cppcheck
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 78139e4cfe37c56bb8e06a2574c7d476d9607af9
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 16:46:15 2022 -0800

    Remove register keyword from variable declarations
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 2c49a8335a953206ce8603c5522153c59e1f7a0d
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Tue Dec 6 16:42:35 2022 -0800

    Reformat code into X.Org standard coding style
    
    Make indentation and formatting much more consistent across this project
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>



More information about the xorg-commit mailing list