libXvMC: Changes to 'master'

GitLab Mirror gitlab-mirror at kemper.freedesktop.org
Sat Mar 25 16:39:24 UTC 2023


 src/XvMC.c            |   96 +++++++++++++++++++++++---------------------------
 src/XvMClibint.h      |   14 ++-----
 wrapper/XvMCWrapper.c |   24 ++++++------
 3 files changed, 63 insertions(+), 71 deletions(-)

New commits:
commit 76c83199fce3a54f78a2a167037db7460c7161f4
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Sun Mar 19 14:26:55 2023 -0700

    Handle implicit conversion warnings from clang
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 5e66fb64762b6d442a55d0506b07be18aeee7643
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Sun Mar 19 13:51:24 2023 -0700

    Replace custom copy of GetReq macro with call to Xlib 1.5's _XGetRequest
    
    XvMCproto.h names don't match those required by the Xlibint.h GetReq*
    macros, but at least we can rely on the _XGetRequest function for the
    bulk of the work now, instead of duplicating it.
    
    Continues to use sizeof() instead of SIZEOF() due to stray ; on the
    end of many sz_* definitions in XvMCproto.h, but I've verified the
    sizes are the same with both methods.
    
    Also clears clang warnings that were repeated for every call:
    
    XvMC.c:79:5: warning: cast from 'char *' to 'xvmcQueryVersionReq *'
      increases required alignment from 1 to 2 [-Wcast-align]
        XvMCGetReq(QueryVersion, req);
        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ./XvMClibint.h:16:8: note: expanded from macro 'XvMCGetReq'
            req = (xvmc##name##Req *)(dpy->last_req = dpy->bufptr);\
                  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    XvMC.c:79:5: warning: implicit conversion loses integer precision:
      'int' to 'CARD8' (aka 'unsigned char') [-Wconversion]
        XvMCGetReq(QueryVersion, req);
        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ./XvMClibint.h:17:30: note: expanded from macro 'XvMCGetReq'
            req->reqType = info->codes->major_opcode;\
                         ~ ~~~~~~~~~~~~~^~~~~~~~~~~~
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>

commit 58073bc12d17341cb9459f36caf161256fc8be19
Author: Alan Coopersmith <alan.coopersmith at oracle.com>
Date:   Sun Mar 19 12:49:56 2023 -0700

    Variable scope reductions as recommended by cppcheck
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith at oracle.com>



More information about the xorg-commit mailing list